aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-LDAP
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-26 04:29:00 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-26 04:29:00 +0000
commitc171ec482c1c8e89b98e0dbef206ad533054b286 (patch)
treecce07555024cd28899d23344a6dc1f8c1863ed7b /databases/p5-DBD-LDAP
parent73ec1cec8d8e735d20695cb2096d18c163d4561b (diff)
downloadports-c171ec482c1c8e89b98e0dbef206ad533054b286.tar.gz
ports-c171ec482c1c8e89b98e0dbef206ad533054b286.zip
Notes
Diffstat (limited to 'databases/p5-DBD-LDAP')
-rw-r--r--databases/p5-DBD-LDAP/Makefile27
-rw-r--r--databases/p5-DBD-LDAP/distinfo1
-rw-r--r--databases/p5-DBD-LDAP/pkg-comment1
-rw-r--r--databases/p5-DBD-LDAP/pkg-descr8
-rw-r--r--databases/p5-DBD-LDAP/pkg-plist9
5 files changed, 46 insertions, 0 deletions
diff --git a/databases/p5-DBD-LDAP/Makefile b/databases/p5-DBD-LDAP/Makefile
new file mode 100644
index 000000000000..4415de6ef8bb
--- /dev/null
+++ b/databases/p5-DBD-LDAP/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: DBD::LDAP
+# Date created: 24 Jan 2002
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBD-LDAP
+PORTVERSION= 0.04
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+MAN3= DBD::LDAP.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBD-LDAP/distinfo b/databases/p5-DBD-LDAP/distinfo
new file mode 100644
index 000000000000..c09e854a4e9c
--- /dev/null
+++ b/databases/p5-DBD-LDAP/distinfo
@@ -0,0 +1 @@
+MD5 (DBD-LDAP-0.04.tar.gz) = da4340d1897854bd46888fa6d6941ff1
diff --git a/databases/p5-DBD-LDAP/pkg-comment b/databases/p5-DBD-LDAP/pkg-comment
new file mode 100644
index 000000000000..2d32b444dabc
--- /dev/null
+++ b/databases/p5-DBD-LDAP/pkg-comment
@@ -0,0 +1 @@
+DBI interface for accessing LDAP servers
diff --git a/databases/p5-DBD-LDAP/pkg-descr b/databases/p5-DBD-LDAP/pkg-descr
new file mode 100644
index 000000000000..8a1aa8a2668b
--- /dev/null
+++ b/databases/p5-DBD-LDAP/pkg-descr
@@ -0,0 +1,8 @@
+DBD::LDAP is a DBI extension module adding an SQL database interface to
+standard LDAP databases to Perl's database-independent database interface.
+You will need access to an existing LDAP database or set up your own using
+an LDAP server, ie. "OpenLDAP".
+
+WWW: http://search.cpan.org/search?dist=DBD-LDAP
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/databases/p5-DBD-LDAP/pkg-plist b/databases/p5-DBD-LDAP/pkg-plist
new file mode 100644
index 000000000000..355365d9a8f5
--- /dev/null
+++ b/databases/p5-DBD-LDAP/pkg-plist
@@ -0,0 +1,9 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBD/LDAP/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/DBD/LDAP.pm
+lib/perl5/site_perl/%%PERL_VER%%/JLdap.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/DBD/LDAP/autosplit.ix
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/DBD/LDAP 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/DBD 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/DBD 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBD/LDAP 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBD 2>/dev/null || true