aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-Oracle/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2007-07-03 18:35:03 +0000
committerErwin Lansing <erwin@FreeBSD.org>2007-07-03 18:35:03 +0000
commit5a603e32e6ca8333270771d9075c6cd797540086 (patch)
treec4b5d19181ffb474fc05e122aa44cf4e11dc2425 /databases/p5-DBD-Oracle/Makefile
parentb4c018da441e76733cf909aae147b5ba7adeadfd (diff)
downloadports-5a603e32e6ca8333270771d9075c6cd797540086.tar.gz
ports-5a603e32e6ca8333270771d9075c6cd797540086.zip
Notes
Diffstat (limited to 'databases/p5-DBD-Oracle/Makefile')
-rw-r--r--databases/p5-DBD-Oracle/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/databases/p5-DBD-Oracle/Makefile b/databases/p5-DBD-Oracle/Makefile
index 7c9f21ddd684..1203c1dd3a47 100644
--- a/databases/p5-DBD-Oracle/Makefile
+++ b/databases/p5-DBD-Oracle/Makefile
@@ -18,6 +18,7 @@ COMMENT= DBI driver for Oracle RDBMS server
OPTIONS= OCI8 "Use OCI8" off
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -42,24 +43,15 @@ post-install:
PORTVERSION= 1.19
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
ORACLE_HOME= ${LOCALBASE}/oracle8-client
-BUILD_DEPENDS= ${ORACLE_HOME}/lib/libclntst8.a:${PORTSDIR}/databases/oracle8-client
+BUILD_DEPENDS+= ${ORACLE_HOME}/lib/libclntst8.a:${PORTSDIR}/databases/oracle8-client
CONFIGURE_ARGS= -V 8.1.7
.else
PORTVERSION= 1.14
ORACLE_HOME= ${LOCALBASE}/oracle7
-BUILD_DEPENDS= ${ORACLE_HOME}/rdbms/demo/oracle.mk:${PORTSDIR}/databases/oracle7-client
+BUILD_DEPENDS+= ${ORACLE_HOME}/rdbms/demo/oracle.mk:${PORTSDIR}/databases/oracle7-client
CONFIGURE_ARGS= -m ${ORACLE_HOME}/rdbms/demo/oracle.mk
.endif
-.if ${PERL_LEVEL} < 500600
-.ifdef WITH_OCI8
-IGNORE= perl 5.6 or newer required. Install lang/perl5.8 and try again
-.endif
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-
post-patch:
.ifdef WITH_OCI8
@${MV} ${WRKSRC}/Oracle.ex/README ${WRKSRC}/Oracle.ex/Readme