aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-Pg/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-09-16 05:43:52 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-09-16 05:43:52 +0000
commit6b470bae86247b8cb79b0dc6e43078df2f84c4ae (patch)
treee1545740f8801646e19c181252cb4c4e39df9ca8 /databases/p5-DBD-Pg/Makefile
parentb63d72fe5f0a821fa729c344f9b44de714603abc (diff)
downloadports-6b470bae86247b8cb79b0dc6e43078df2f84c4ae.tar.gz
ports-6b470bae86247b8cb79b0dc6e43078df2f84c4ae.zip
Notes
Diffstat (limited to 'databases/p5-DBD-Pg/Makefile')
-rw-r--r--databases/p5-DBD-Pg/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/databases/p5-DBD-Pg/Makefile b/databases/p5-DBD-Pg/Makefile
index d7cf0e3fc235..94e3f269a968 100644
--- a/databases/p5-DBD-Pg/Makefile
+++ b/databases/p5-DBD-Pg/Makefile
@@ -16,9 +16,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= fjoe@freebsd.org
COMMENT= Provides access to PostgreSQL databases through the DBI
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
-RUN_DEPENDS= ${BUILD_DEPENDS}
POSTGRESQL_PORT?= databases/postgresql7
@@ -26,7 +24,17 @@ PERL_CONFIGURE= yes
MAN3= DBD::Pg.3 DBD::dbd-pg.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>
.if defined(WITH_OLD_LAYOUT)
CONFIGURE_ENV+= POSTGRES_INCLUDE=${LOCALBASE}/include/pgsql \