aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-Pg
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-17 02:37:15 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-17 02:37:15 +0000
commit1e60866cc19e399726a715fe8f90de75614755d9 (patch)
tree919603a1bf324ecbe31827d6a9441e11e58f98a0 /databases/p5-DBD-Pg
parent30563b53998852429b379c5698be8bc307cc56ca (diff)
downloadports-1e60866cc19e399726a715fe8f90de75614755d9.tar.gz
ports-1e60866cc19e399726a715fe8f90de75614755d9.zip
Notes
Diffstat (limited to 'databases/p5-DBD-Pg')
-rw-r--r--databases/p5-DBD-Pg/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/databases/p5-DBD-Pg/Makefile b/databases/p5-DBD-Pg/Makefile
index c5e3167831a5..cbe362cf3ff7 100644
--- a/databases/p5-DBD-Pg/Makefile
+++ b/databases/p5-DBD-Pg/Makefile
@@ -5,25 +5,26 @@
# $FreeBSD$
#
-PORTNAME= p5-DBD-Pg
+PORTNAME= DBD-Pg
PORTVERSION= 0.93
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBD
-DISTNAME= DBD-Pg-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= jfitz@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql
-USE_PERL5= YES
-CONFIGURE_ENV= POSTGRES_INCLUDE=${PREFIX}/pgsql/include POSTGRES_LIB=${PREFIX}/pgsql/lib
+USE_PERL5= yes
+MAKE_ENV= POSTGRES_INCLUDE=${PREFIX}/pgsql/include POSTGRES_LIB=${PREFIX}/pgsql/lib
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= DBD::Pg.3 DBD::dbd-pg.3
do-configure:
- @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.mk>