aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-Pg
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /databases/p5-DBD-Pg
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'databases/p5-DBD-Pg')
-rw-r--r--databases/p5-DBD-Pg/Makefile3
-rw-r--r--databases/p5-DBD-Pg/pkg-plist7
2 files changed, 5 insertions, 5 deletions
diff --git a/databases/p5-DBD-Pg/Makefile b/databases/p5-DBD-Pg/Makefile
index a548f167f989..7dc394fe4fd7 100644
--- a/databases/p5-DBD-Pg/Makefile
+++ b/databases/p5-DBD-Pg/Makefile
@@ -2,6 +2,7 @@
PORTNAME= DBD-Pg
PORTVERSION= 3.4.1
+PORTREVISION= 1
CATEGORIES= databases perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -19,6 +20,6 @@ USES= pgsql perl5
USE_PERL5= configure
post-stage:
- ${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/DBD/Pg/Pg.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/DBD/Pg/Pg.so
.include <bsd.port.mk>
diff --git a/databases/p5-DBD-Pg/pkg-plist b/databases/p5-DBD-Pg/pkg-plist
index 8e5318c57453..9d2cfe7c492c 100644
--- a/databases/p5-DBD-Pg/pkg-plist
+++ b/databases/p5-DBD-Pg/pkg-plist
@@ -1,6 +1,5 @@
%%PERL5_MAN3%%/Bundle::DBD::Pg.3.gz
%%PERL5_MAN3%%/DBD::Pg.3.gz
-%%SITE_PERL%%/%%PERL_ARCH%%/Bundle/DBD/Pg.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/DBD/Pg.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/Pg/.packlist
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/Pg/Pg.so
+%%SITE_ARCH%%/Bundle/DBD/Pg.pm
+%%SITE_ARCH%%/DBD/Pg.pm
+%%SITE_ARCH%%/auto/DBD/Pg/Pg.so