aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-PgSPI/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-10-03 16:10:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-10-03 16:10:41 +0000
commit9021e7995827766a7de44c7e8835120816346f9c (patch)
tree28a4df8f6ff4a483822bd3d10301b693effb072c /databases/p5-DBD-PgSPI/Makefile
parent959ae08171f451eaabe27038fbb59f27eaba5b25 (diff)
downloadports-9021e7995827766a7de44c7e8835120816346f9c.tar.gz
ports-9021e7995827766a7de44c7e8835120816346f9c.zip
Notes
Diffstat (limited to 'databases/p5-DBD-PgSPI/Makefile')
-rw-r--r--databases/p5-DBD-PgSPI/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/databases/p5-DBD-PgSPI/Makefile b/databases/p5-DBD-PgSPI/Makefile
new file mode 100644
index 000000000000..febaf067bedd
--- /dev/null
+++ b/databases/p5-DBD-PgSPI/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: p5-DBD-PgSPI
+# Date created: 17 April 2003
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBD-PgSPI
+PORTVERSION= 0.01
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Provides access to PostgreSQL db through DBI within pl/perl functions
+
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ ${NONEXISTENT}:${PORTSDIR}/${POSTGRESQL_PORT}:configure
+RUN_DEPENDS= ${LOCALBASE}/lib/postgresql/plperl.so:${PORTSDIR}/databases/p5-postgresql-plperl \
+ ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+LIB_DEPENDS= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+
+PERL_CONFIGURE= yes
+
+MAN3= DBD::PgSPI.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+POSTGRESQL_PORT?= databases/postgresql7
+PGSQL_PORTDIR?= ${PORTSDIR}/${POSTGRESQL_PORT}
+PGSQL_WRKSRC!= cd ${PGSQL_PORTDIR} && ${MAKE} -V WRKSRC
+
+CONFIGURE_ENV= POSTGRES_HOME="${PGSQL_WRKSRC}/src" \
+ LOCALBASE="${LOCALBASE}"
+
+post-clean:
+ @cd ${PGSQL_PORTDIR} && ${MAKE} clean
+
+.include <bsd.port.post.mk>