aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-SQLite
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2006-09-12 13:29:00 +0000
committerMathieu Arnold <mat@FreeBSD.org>2006-09-12 13:29:00 +0000
commit1233c00f46b3156a84e8370551b0fac79bd3f11a (patch)
tree42f007f67e13d5bc483392d3dac56c4ebd317410 /databases/p5-DBD-SQLite
parenta755774481dea7df75b7a44eb450613fb766f2cf (diff)
downloadports-1233c00f46b3156a84e8370551b0fac79bd3f11a.tar.gz
ports-1233c00f46b3156a84e8370551b0fac79bd3f11a.zip
Notes
Diffstat (limited to 'databases/p5-DBD-SQLite')
-rw-r--r--databases/p5-DBD-SQLite/Makefile2
-rw-r--r--databases/p5-DBD-SQLite/distinfo6
-rw-r--r--databases/p5-DBD-SQLite/files/patch-Makefile.PL20
-rw-r--r--databases/p5-DBD-SQLite/files/patch-dbdimp.h9
4 files changed, 11 insertions, 26 deletions
diff --git a/databases/p5-DBD-SQLite/Makefile b/databases/p5-DBD-SQLite/Makefile
index 681a9230256e..c658e7f26e04 100644
--- a/databases/p5-DBD-SQLite/Makefile
+++ b/databases/p5-DBD-SQLite/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= DBD-SQLite
-PORTVERSION= 1.12
+PORTVERSION= 1.13
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBD
diff --git a/databases/p5-DBD-SQLite/distinfo b/databases/p5-DBD-SQLite/distinfo
index 8ad820f01372..17e51159c348 100644
--- a/databases/p5-DBD-SQLite/distinfo
+++ b/databases/p5-DBD-SQLite/distinfo
@@ -1,3 +1,3 @@
-MD5 (DBD-SQLite-1.12.tar.gz) = 40b1d208d70d5d8cab7723df96fc239c
-SHA256 (DBD-SQLite-1.12.tar.gz) = 37ad91ec0cec17c07f367b1aa974e3fd2b719e4a1cbb16e06b1799ed112ae2bd
-SIZE (DBD-SQLite-1.12.tar.gz) = 547151
+MD5 (DBD-SQLite-1.13.tar.gz) = d33e584f435d464a55946f58d4d4b9e2
+SHA256 (DBD-SQLite-1.13.tar.gz) = 7298060b241260af0b495840aec358bd27b0b2bf2e0b6bcf1dbc0743229ee412
+SIZE (DBD-SQLite-1.13.tar.gz) = 582465
diff --git a/databases/p5-DBD-SQLite/files/patch-Makefile.PL b/databases/p5-DBD-SQLite/files/patch-Makefile.PL
index e458f994f0c8..e1b1e6f1d68f 100644
--- a/databases/p5-DBD-SQLite/files/patch-Makefile.PL
+++ b/databases/p5-DBD-SQLite/files/patch-Makefile.PL
@@ -1,6 +1,6 @@
---- Makefile.PL.orig Fri Aug 5 19:15:09 2005
-+++ Makefile.PL Wed Apr 12 11:13:37 2006
-@@ -65,31 +65,31 @@ if ($force_local = (grep(/USE_LOCAL_SQLI
+--- Makefile.PL.orig Fri Sep 8 05:45:13 2006
++++ Makefile.PL Tue Sep 12 13:59:02 2006
+@@ -68,31 +68,31 @@
# Now, check for a compatible sqlite3
unless ($force_local) {
@@ -39,17 +39,3 @@
last if $version;
}
}
-@@ -115,11 +115,11 @@ WriteMakefile(
- 'OBJECT' => ($force_local) ? '$(O_FILES)' : 'SQLite.o dbdimp.o',
- 'INC' => '-I. -I$(DBI_INSTARCH_DIR)' .
- (($sqlite_inc) ? " -I$sqlite_inc" : ''),
-- $force_local ? () : ('LIBS' => '-lsqlite3'),
-+ $force_local ? () : ('LIBS' => $sqlite_lib ? "-L$sqlite_lib -lsqlite3" : "-lsqlite3"),
- $sqlite_lib ? ('dynamic_lib' => { OTHERLDFLAGS => "-L$sqlite_lib" }) : (),
- 'OPTIMIZE' => "-O2",
- 'DEFINE' => "-DNDEBUG=1 -DSQLITE_PTR_SZ=$Config{ptrsize}" .
-- ( ($Config{d_usleep} ||
-+ ( (1 ||
- $Config{osname} =~ m/linux/) ?
- " -DHAVE_USLEEP=1" : "" ) .
- ($DBI::VERSION > 1.42 ? '' : ' -Dno_last_insert_id'),
diff --git a/databases/p5-DBD-SQLite/files/patch-dbdimp.h b/databases/p5-DBD-SQLite/files/patch-dbdimp.h
index ba359752604a..4506595aca58 100644
--- a/databases/p5-DBD-SQLite/files/patch-dbdimp.h
+++ b/databases/p5-DBD-SQLite/files/patch-dbdimp.h
@@ -1,10 +1,9 @@
---- dbdimp.h.orig Sat Sep 11 00:24:28 2004
-+++ dbdimp.h Mon Dec 27 16:37:25 2004
-@@ -99,6 +99,10 @@
- #define newUTF8SVpv newSVpv
+--- dbdimp.h.orig Fri Sep 8 06:50:50 2006
++++ dbdimp.h Tue Sep 12 14:00:36 2006
+@@ -105,6 +105,9 @@
#define newUTF8SVpvn newSVpvn
#define SvUTF8_on(a) (a)
-+#define SvUTF8_off(a) (a)
+ #define SvUTF8_off(a) (a)
+#ifndef get_sv
+#define get_sv perl_get_sv
+#endif