aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-XBase/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-09-19 17:06:01 +0000
committerAde Lovett <ade@FreeBSD.org>2000-09-19 17:06:01 +0000
commite40e2d85f603d4e5695a90f188703d63f55e7258 (patch)
tree43946d80394869c8a20a177bc00c0075d9c4aa98 /databases/p5-DBD-XBase/Makefile
parentdf901763633404e5aea9ff3e0eeb0502a20898ad (diff)
Notes
Diffstat (limited to 'databases/p5-DBD-XBase/Makefile')
-rw-r--r--databases/p5-DBD-XBase/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/databases/p5-DBD-XBase/Makefile b/databases/p5-DBD-XBase/Makefile
new file mode 100644
index 000000000000..a91b2f3570f6
--- /dev/null
+++ b/databases/p5-DBD-XBase/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-DBD-XBase
+# Date created: 10th September 2000
+# Whom: Ilia Chipitsine <ilia@jane.cgu.chel.su>
+#
+# $FreeBSD$
+
+PORTNAME= DBD-XBase
+PORTVERSION= 0.161
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ilia@cgu.chel.su
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+
+USE_PERL5= yes
+
+GZIP= -9
+
+MAN1= dbfdump.1 indexdump.1
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= XBase::FAQ.3 XBase::Memo.3 XBase::Index.3 XBase.3 \
+ DBD::XBase.3 XBase::Base.3
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/dbfdump ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/indexdump ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/blib/man1/dbfdump.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/blib/man1/indexdump.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>