aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-cego
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-10-01 23:16:23 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-10-01 23:16:23 +0000
commit68b4db74a3d203a80a5b124042696d2d5afc21cd (patch)
tree91a8a27ffe28de2451279b2e6322d41b80e5ea64 /databases/p5-DBD-cego
parent115141529cc29371f6a56a0f5c42d4f77fe0369e (diff)
downloadports-68b4db74a3d203a80a5b124042696d2d5afc21cd.tar.gz
ports-68b4db74a3d203a80a5b124042696d2d5afc21cd.zip
Notes
Diffstat (limited to 'databases/p5-DBD-cego')
-rw-r--r--databases/p5-DBD-cego/Makefile13
-rw-r--r--databases/p5-DBD-cego/distinfo6
-rw-r--r--databases/p5-DBD-cego/files/patch-makefile-pl27
3 files changed, 20 insertions, 26 deletions
diff --git a/databases/p5-DBD-cego/Makefile b/databases/p5-DBD-cego/Makefile
index e8887fff2c37..bbb5234a7aa4 100644
--- a/databases/p5-DBD-cego/Makefile
+++ b/databases/p5-DBD-cego/Makefile
@@ -5,26 +5,21 @@
# $FreeBSD$
PORTNAME= DBD-cego
-PORTVERSION= 1.1.9
-PORTREVISION= 1
+PORTVERSION= 1.1.13
CATEGORIES= databases perl5
MASTER_SITES= http://www.lemke-it.com/
PKGNAMEPREFIX= p5-
-DISTNAME= DBD-cego-${PORTVERSION}
MAINTAINER= fbsd-ports@opsec.eu
COMMENT= A Cego DBI driver for Perl 5
BUILD_DEPENDS= p5-DBI>=1.61:${PORTSDIR}/databases/p5-DBI
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
LIB_DEPENDS= cego.1:${PORTSDIR}/databases/cego
-BROKEN= does not compile, lots of bad c++/xs code
-
LICENSE= GPLv2
-WRKSRC= ${WRKDIR}/DBD-cego
-PERL_CONFIGURE= yes
-CC= g++
+PERL_CONFIGURE= yes
+CC:= ${CXX}
MAN3= DBD::Cego.3
diff --git a/databases/p5-DBD-cego/distinfo b/databases/p5-DBD-cego/distinfo
index db13d4599df7..6ac37ee98e65 100644
--- a/databases/p5-DBD-cego/distinfo
+++ b/databases/p5-DBD-cego/distinfo
@@ -1,3 +1,3 @@
-MD5 (DBD-cego-1.1.9.tar.gz) = 4c220989e07557873b7ce3e67420897f
-SHA256 (DBD-cego-1.1.9.tar.gz) = 21a9c28961a9c84716220959c9bde77de3a45344f1cc53e51a732adc43ceda84
-SIZE (DBD-cego-1.1.9.tar.gz) = 23577
+MD5 (DBD-cego-1.1.13.tar.gz) = f54c7337777b0d7fdc23707e221f7c23
+SHA256 (DBD-cego-1.1.13.tar.gz) = dceaabc9e7ab6d6607f8f0a94f385e31c94ee0d70692de75b6355e2acfcd0add
+SIZE (DBD-cego-1.1.13.tar.gz) = 23241
diff --git a/databases/p5-DBD-cego/files/patch-makefile-pl b/databases/p5-DBD-cego/files/patch-makefile-pl
index 239684acb453..15e02a11844a 100644
--- a/databases/p5-DBD-cego/files/patch-makefile-pl
+++ b/databases/p5-DBD-cego/files/patch-makefile-pl
@@ -1,6 +1,6 @@
---- Makefile.PL 2010-07-02 21:08:00.000000000 +0200
-+++ Makefile.PL-new 2010-07-02 21:19:41.000000000 +0200
-@@ -29,24 +29,16 @@
+--- Makefile.PL.orig 2010-09-17 10:14:49.000000000 +0200
++++ Makefile.PL 2010-09-17 21:51:58.000000000 +0200
+@@ -29,12 +29,6 @@
"verbose",
) || die Usage();
@@ -11,24 +11,22 @@
-}
-
use vars qw($loadlibs);
--$loadlibs= "-L" . $opt->{'prefix'} . " -lBase";
-+$loadlibs= " -lBase";
+ $loadlibs= "-L" . $opt->{'prefix'} . " -llfc";
- WriteMakefile(
- 'NAME' => 'DBD::Cego',
+@@ -43,10 +37,8 @@
'VERSION_FROM' => 'Cego.pm',
'PREREQ_PM' => {DBI => 1.03},
'OBJECT' => '$(O_FILES)',
-- 'INC' => '-I$(DBI_INSTARCH_DIR) -I' . $opt->{'prefix'} . '/include',
+- 'INC' => '-I$(DBI_INSTARCH_DIR) -I' . $opt->{'prefix'} . '/include -I' . $opt->{'prefix'} . '/include',
- 'MYEXTLIB' => $opt->{'prefix'} . "/lib/libcego.a "
-- . $opt->{'prefix'} . "/lib/libXML.a "
-- . $opt->{'prefix'} . "/lib/libBase.a",
-+ 'INC' => '-I$(DBI_INSTARCH_DIR) -I/usr/local/include',
-+ 'MYEXTLIB' => " -lcego -lXML -lBase ",
+- . $opt->{'prefix'} . "/lib/liblfcxml.a "
+- . $opt->{'prefix'} . "/lib/liblfc.a",
++ 'INC' => '-I$(DBI_INSTARCH_DIR) -I/usr/local/include -I' . $opt->{'prefix'} . '/include',
++ 'MYEXTLIB' => ' -llfc -llfcxml -lcego ',
"CC" => "g++",
"LD" => "g++",
"XSPROTOARG" => "-noprototypes",
-@@ -58,12 +50,7 @@
+@@ -58,13 +50,7 @@
sub Usage {
print STDERR <<"USAGE";
@@ -38,7 +36,8 @@
-
- --prefix=<prefix path> Use <prefix> for setting up the appropriate prefix path
- to find cego libs and includes
+-
+Usage: perl $0
-
USAGE
exit 1;
+ }