aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-mysql/Makefile
diff options
context:
space:
mode:
authorJames FitzGibbon <jfitz@FreeBSD.org>1997-06-18 19:39:25 +0000
committerJames FitzGibbon <jfitz@FreeBSD.org>1997-06-18 19:39:25 +0000
commit0fa2622346e9f7588ab215f3745705a03db0f16c (patch)
tree3d6b7c68d1b364694d94ab37976b8318227e8b38 /databases/p5-DBD-mysql/Makefile
parent6a10d5281714c72959930c73ba2d7c94fa63d24b (diff)
downloadports-0fa2622346e9f7588ab215f3745705a03db0f16c.tar.gz
ports-0fa2622346e9f7588ab215f3745705a03db0f16c.zip
Notes
Diffstat (limited to 'databases/p5-DBD-mysql/Makefile')
-rw-r--r--databases/p5-DBD-mysql/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/databases/p5-DBD-mysql/Makefile b/databases/p5-DBD-mysql/Makefile
new file mode 100644
index 000000000000..8d294ec30d49
--- /dev/null
+++ b/databases/p5-DBD-mysql/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-MySQL
+# Version required: 1.17
+# Date created: June 17th 1997
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= Mysqlperl-1.17
+PKGNAME= p5-Mysql-1.17
+CATEGORIES= databases perl5
+MASTER_SITES= http://www.tcx.se/Contrib/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jfitz@FreeBSD.ORG
+
+BUILD_DEPENDS= perl5.004:${PORTSDIR}/lang/perl5 \
+ ${PREFIX}/lib/mysql/libmysqlclient.a:${PORTSDIR}/databases/mysql
+RUN_DEPENDS= perl5.004:${PORTSDIR}/lang/perl5
+
+MAN3= Mysql.3
+MANPREFIX= ${PREFIX}/lib/perl5
+
+CONFIGURE_ENV+= PREFIX=${PREFIX}
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PREFIX}/bin/perl Makefile.PL
+
+.include <bsd.port.mk>