aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBD-mysql
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-09-14 17:31:34 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-09-14 17:31:34 +0000
commit0dc1587de9d2e9b40eca2c42c36e2830aa4dd65b (patch)
treea2ae9759ce375808c7c0af39dc1aaa50bf4929c1 /databases/p5-DBD-mysql
parentc4203a8dce1d2582c506dcf529bb2bbaff5b230f (diff)
downloadports-0dc1587de9d2e9b40eca2c42c36e2830aa4dd65b.tar.gz
ports-0dc1587de9d2e9b40eca2c42c36e2830aa4dd65b.zip
Notes
Diffstat (limited to 'databases/p5-DBD-mysql')
-rw-r--r--databases/p5-DBD-mysql/Makefile2
-rw-r--r--databases/p5-DBD-mysql/files/patch-dbdimp.c22
2 files changed, 23 insertions, 1 deletions
diff --git a/databases/p5-DBD-mysql/Makefile b/databases/p5-DBD-mysql/Makefile
index aa58fdbc86d4..c7516f8a8cf6 100644
--- a/databases/p5-DBD-mysql/Makefile
+++ b/databases/p5-DBD-mysql/Makefile
@@ -7,7 +7,7 @@
PORTNAME= DBD-mysql
PORTVERSION= 3.0007
-PORTREVISION= 0
+PORTREVISION?= 0
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBD
diff --git a/databases/p5-DBD-mysql/files/patch-dbdimp.c b/databases/p5-DBD-mysql/files/patch-dbdimp.c
new file mode 100644
index 000000000000..9fa0067f11f6
--- /dev/null
+++ b/databases/p5-DBD-mysql/files/patch-dbdimp.c
@@ -0,0 +1,22 @@
+#
+# Fix build with old gcc
+#
+--- dbdimp.c.orig Fri Sep 8 17:25:59 2006
++++ dbdimp.c Thu Sep 14 10:31:47 2006
+@@ -2347,6 +2347,7 @@
+ char *table;
+ char *salloc;
+ int htype;
++ my_ulonglong rows= 0;
+
+ /* thank you DBI.c for this info! */
+ D_imp_xxh(h);
+@@ -2386,8 +2387,6 @@
+ params,
+ num_params,
+ imp_dbh->bind_type_guessing);
+-
+- my_ulonglong rows= 0;
+
+ if (dbis->debug >= 2)
+ PerlIO_printf(DBILOGFP, "mysql_st_internal_execute\n");