aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Admin-DSNManager
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-03-11 18:01:06 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-03-11 18:01:06 +0000
commit809b9922c333f93606e2bf8b7f279b9d6f71593b (patch)
tree3699d1a182d66a1e90d3f6d126894a256f288bdc /databases/p5-DBIx-Admin-DSNManager
parent7ed78b03994e0380346c04d14d17a5f3def27d8a (diff)
downloadports-809b9922c333f93606e2bf8b7f279b9d6f71593b.tar.gz
ports-809b9922c333f93606e2bf8b7f279b9d6f71593b.zip
Notes
Diffstat (limited to 'databases/p5-DBIx-Admin-DSNManager')
-rw-r--r--databases/p5-DBIx-Admin-DSNManager/Makefile27
-rw-r--r--databases/p5-DBIx-Admin-DSNManager/distinfo2
-rw-r--r--databases/p5-DBIx-Admin-DSNManager/pkg-descr24
-rw-r--r--databases/p5-DBIx-Admin-DSNManager/pkg-plist8
4 files changed, 61 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Admin-DSNManager/Makefile b/databases/p5-DBIx-Admin-DSNManager/Makefile
new file mode 100644
index 000000000000..cceff74a0fd4
--- /dev/null
+++ b/databases/p5-DBIx-Admin-DSNManager/Makefile
@@ -0,0 +1,27 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= DBIx-Admin-DSNManager
+PORTVERSION= 2.01
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Manage a file of DSNs, for both testing and production
+
+LICENSE= ART20
+
+BUILD_DEPENDS= p5-Config-Tiny>=2.12:${PORTSDIR}/devel/p5-Config-Tiny \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-File-Slurp>=9999.13:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-Moo>=1.004002:${PORTSDIR}/devel/p5-Moo
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Version>=1.002.003:${PORTSDIR}/devel/p5-Test-Version \
+ p5-Try-Tiny>=0.06:${PORTSDIR}/lang/p5-Try-Tiny
+
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Admin-DSNManager/distinfo b/databases/p5-DBIx-Admin-DSNManager/distinfo
new file mode 100644
index 000000000000..53876ae51f5d
--- /dev/null
+++ b/databases/p5-DBIx-Admin-DSNManager/distinfo
@@ -0,0 +1,2 @@
+SHA256 (DBIx-Admin-DSNManager-2.01.tgz) = e8c8a99ab82e6decbfec3523771f4a16de1005146f19164c47294e1f5d3aac6a
+SIZE (DBIx-Admin-DSNManager-2.01.tgz) = 10761
diff --git a/databases/p5-DBIx-Admin-DSNManager/pkg-descr b/databases/p5-DBIx-Admin-DSNManager/pkg-descr
new file mode 100644
index 000000000000..381ce7d48f47
--- /dev/null
+++ b/databases/p5-DBIx-Admin-DSNManager/pkg-descr
@@ -0,0 +1,24 @@
+DBIx::Admin::DSNManager manages a file of DSNs, for both testing and production.
+
+The INI-style format was selected, rather than, say, using an SQLite database,
+so that casual users could edit the file without needing to know SQL and without
+having to install the command line program sqlite3.
+
+Each DSN is normally for something requiring manual preparation, such as
+creating the database named in the DSN.
+
+In the case of SQLite, etc, where manual intervention is not required, you can
+still put the DSN in dsn.ini.
+
+One major use of this module is to avoid environment variable overload, since it
+is common to test Perl modules by setting the env vars $DBI_DSN, $DBI_USER and
+$DBI_PASS.
+
+But then the problem becomes: What do you do when you want to run tests against
+a set of databases servers? Some modules define sets of env vars, one set per
+database server, with awkward and hard-to-guess names. This is messy and
+obscure.
+
+DBIx::Admin::DSNManager is a solution to this problem.
+
+WWW: http://search.cpan.org/dist/DBIx-Admin-DSNManager/
diff --git a/databases/p5-DBIx-Admin-DSNManager/pkg-plist b/databases/p5-DBIx-Admin-DSNManager/pkg-plist
new file mode 100644
index 000000000000..fa938b85bed3
--- /dev/null
+++ b/databases/p5-DBIx-Admin-DSNManager/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/DBIx/Admin/DSNManager.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Admin/DSNManager/.packlist
+%%PERL5_MAN3%%/DBIx::Admin::DSNManager.3.gz
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Admin/DSNManager
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Admin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx
+@dirrmtry %%SITE_PERL%%/DBIx/Admin
+@dirrmtry %%SITE_PERL%%/DBIx