aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Class-Candy/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2012-06-14 01:27:50 +0000
committerWen Heping <wen@FreeBSD.org>2012-06-14 01:27:50 +0000
commit08ef42c65523d2848b3e30fcf12dc4be39efe898 (patch)
tree35fcc8cdc83ebdaa0827d4bbd92c8a89a19f5933 /databases/p5-DBIx-Class-Candy/Makefile
parentfb394501553e504f039da215dadad14aaead0dbd (diff)
downloadports-08ef42c65523d2848b3e30fcf12dc4be39efe898.tar.gz
ports-08ef42c65523d2848b3e30fcf12dc4be39efe898.zip
Notes
Diffstat (limited to 'databases/p5-DBIx-Class-Candy/Makefile')
-rw-r--r--databases/p5-DBIx-Class-Candy/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Class-Candy/Makefile b/databases/p5-DBIx-Class-Candy/Makefile
new file mode 100644
index 000000000000..7b6e92031fe4
--- /dev/null
+++ b/databases/p5-DBIx-Class-Candy/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: DBIx-Class-Candy
+# Date created: 09 Jun, 2012
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Class-Candy
+PORTVERSION= 0.002100
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Sugar for your favorite ORM, DBIx::Class
+
+RUN_DEPENDS= p5-DBIx-Class>=0.08123:${PORTSDIR}/databases/p5-DBIx-Class \
+ p5-String-CamelCase>=0:${PORTSDIR}/textproc/p5-String-CamelCase \
+ p5-Lingua-EN-Inflect>=0:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect
+BUILD_DEPENDS= ${RUN_DEPENDS}
+TEST_DEPENDS= p5-Test-Fatal>0:${PORTSDIR}/devel/p5-Test-Fatal \
+ p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Class::Candy.3 \
+ DBIx::Class::Candy::Exports.3
+
+.include <bsd.port.mk>