aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Class-EncodedColumn
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-13 16:15:36 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-13 16:15:36 +0000
commitb59621d3ae883bef429a8fae6073bfa293a55222 (patch)
treeb415c7b2903cf47ada68c5557c3c6ac33a25fc41 /databases/p5-DBIx-Class-EncodedColumn
parente93c09b8f3675471a176b72ae1e6f085f7a607ad (diff)
Notes
Diffstat (limited to 'databases/p5-DBIx-Class-EncodedColumn')
-rw-r--r--databases/p5-DBIx-Class-EncodedColumn/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/databases/p5-DBIx-Class-EncodedColumn/Makefile b/databases/p5-DBIx-Class-EncodedColumn/Makefile
index 2b2f5db177ab..fbc653206a53 100644
--- a/databases/p5-DBIx-Class-EncodedColumn/Makefile
+++ b/databases/p5-DBIx-Class-EncodedColumn/Makefile
@@ -33,10 +33,20 @@ MAN3= DBIx::Class::EncodedColumn.3 \
DBIx::Class::EncodedColumn::Crypt::OpenPGP.3 \
DBIx::Class::EncodedColumn::Digest.3
+post-extract:
+ @${PERL} -i -ne 'print unless m,^build_requires, || m,^feature, .. m,;,' ${WRKSRC}/Makefile.PL
+
OPTIONS= SHA "Digest::SHA Support" On \
BLOWFISH "Blowfish Support?" On \
OPENPGP "Crypt::OpenPGP (gpg) Support" On
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SHA)
+. if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
+. endif
+.endif
.if defined(WITH_BLOWFISH)
RUN_DEPENDS+= p5-Crypt-Eksblowfish>=0:${PORTSDIR}/security/p5-Crypt-Eksblowfish
.endif
@@ -45,7 +55,4 @@ RUN_DEPENDS+= p5-Crypt-OpenPGP>=0:${PORTSDIR}/security/p5-Crypt-OpenPGP \
p5-Crypt-CAST5_PP>=0:${PORTSDIR}/security/p5-Crypt-CAST5_PP
.endif
-post-extract:
- @${PERL} -i -ne 'print unless m,^build_requires, || m,^feature, .. m,;,' ${WRKSRC}/Makefile.PL
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>