aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Class-QueryLog/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-01 21:42:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-01 21:42:51 +0000
commitb79a0bbfeb0883630dd683180969b178ab5236e6 (patch)
tree7a5e7ddd1d6e19b23410a37a7379439e50967fe2 /databases/p5-DBIx-Class-QueryLog/Makefile
parent0236bd0955ed1c2fa42616108bb3efe39fc9fd0c (diff)
downloadports-b79a0bbfeb0883630dd683180969b178ab5236e6.tar.gz
ports-b79a0bbfeb0883630dd683180969b178ab5236e6.zip
Notes
Diffstat (limited to 'databases/p5-DBIx-Class-QueryLog/Makefile')
-rw-r--r--databases/p5-DBIx-Class-QueryLog/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Class-QueryLog/Makefile b/databases/p5-DBIx-Class-QueryLog/Makefile
new file mode 100644
index 000000000000..c66a5fc69176
--- /dev/null
+++ b/databases/p5-DBIx-Class-QueryLog/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: Log-Dispatch-Configurator-YAML
+# Date created: 28 May 2008
+# Whom: Andrey Kostenko <andrey@kostenko.name>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Class-QueryLog
+PORTVERSION= 1.1.5
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= andrey@kostenko.name
+COMMENT= Log queries for later analysis
+
+RUN_DEPENDS= p5-DBIx-Class>=0:${PORTSDIR}/databases/p5-DBIx-Class \
+ p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Class::QueryLog.3 DBIx::Class::QueryLog::Query.3 DBIx::Class::QueryLog::Transaction.3 DBIx::Class::QueryLog::Analyzer.3
+
+.include <bsd.port.mk>