aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-ContextualFetch
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2004-03-22 15:17:41 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2004-03-22 15:17:41 +0000
commit5a74d1f6cc45376186cca3538eb8902dddd12d58 (patch)
treea98416b155f1c791ef3306d732c000f00113c73b /databases/p5-DBIx-ContextualFetch
parent86c296c2984a20e32447acea81a073504bd89ddf (diff)
downloadports-5a74d1f6cc45376186cca3538eb8902dddd12d58.tar.gz
ports-5a74d1f6cc45376186cca3538eb8902dddd12d58.zip
Add p5-DBIx-ContextualFetch 1.01, add contextual fetches to DBI.
Notes
Notes: svn path=/head/; revision=104945
Diffstat (limited to 'databases/p5-DBIx-ContextualFetch')
-rw-r--r--databases/p5-DBIx-ContextualFetch/Makefile36
-rw-r--r--databases/p5-DBIx-ContextualFetch/distinfo2
-rw-r--r--databases/p5-DBIx-ContextualFetch/pkg-descr7
-rw-r--r--databases/p5-DBIx-ContextualFetch/pkg-plist5
4 files changed, 50 insertions, 0 deletions
diff --git a/databases/p5-DBIx-ContextualFetch/Makefile b/databases/p5-DBIx-ContextualFetch/Makefile
new file mode 100644
index 000000000000..dd0d04cadf57
--- /dev/null
+++ b/databases/p5-DBIx-ContextualFetch/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: DBIx-ContextualFetch
+# Date created: 17 March 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-ContextualFetch
+PORTVERSION= 1.01
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx/TMTM
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Add contextual fetches to DBI
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::ContextualFetch.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+.if ${PERL_LEVEL} < 500702
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-DBIx-ContextualFetch/distinfo b/databases/p5-DBIx-ContextualFetch/distinfo
new file mode 100644
index 000000000000..838d673ea2ec
--- /dev/null
+++ b/databases/p5-DBIx-ContextualFetch/distinfo
@@ -0,0 +1,2 @@
+MD5 (DBIx-ContextualFetch-1.01.tar.gz) = d36c5244c73a973a945b9294b619fe49
+SIZE (DBIx-ContextualFetch-1.01.tar.gz) = 3594
diff --git a/databases/p5-DBIx-ContextualFetch/pkg-descr b/databases/p5-DBIx-ContextualFetch/pkg-descr
new file mode 100644
index 000000000000..50c9b176df65
--- /dev/null
+++ b/databases/p5-DBIx-ContextualFetch/pkg-descr
@@ -0,0 +1,7 @@
+DBIx::ContextualFetch redefines some of the various fetch methods to
+add context sensitivity.
+
+WWW: http://search.cpan.org/dist/DBIx-ContextualFetch/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/databases/p5-DBIx-ContextualFetch/pkg-plist b/databases/p5-DBIx-ContextualFetch/pkg-plist
new file mode 100644
index 000000000000..88122395b8de
--- /dev/null
+++ b/databases/p5-DBIx-ContextualFetch/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/ContextualFetch/.packlist
+%%SITE_PERL%%/DBIx/ContextualFetch.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/ContextualFetch
+@unexec rmdir %D/%%SITE_PERL%%/DBIx 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx 2>/dev/null || true