aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Inspector
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-12-26 15:13:51 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-12-26 15:13:51 +0000
commit978d929e39424179215f83766b6714478b772437 (patch)
tree44098fb2ae2e93e0cca65121d623771461efe36f /databases/p5-DBIx-Inspector
parent21a9552b4ce289c55d2502c8c074f0c91eb44a95 (diff)
Notes
Diffstat (limited to 'databases/p5-DBIx-Inspector')
-rw-r--r--databases/p5-DBIx-Inspector/Makefile30
-rw-r--r--databases/p5-DBIx-Inspector/distinfo2
-rw-r--r--databases/p5-DBIx-Inspector/pkg-descr3
-rw-r--r--databases/p5-DBIx-Inspector/pkg-plist19
4 files changed, 54 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Inspector/Makefile b/databases/p5-DBIx-Inspector/Makefile
new file mode 100644
index 000000000000..3b8d365c4be9
--- /dev/null
+++ b/databases/p5-DBIx-Inspector/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: DBIx::Inspector
+# Date created: 26 Dec 2010
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Inspector
+PORTVERSION= 0.04
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to get information from $dbh
+
+RUN_DEPENDS= \
+ p5-Class-Accessor-Lite>0:${PORTSDIR}/devel/p5-Class-Accessor-Lite \
+ p5-DBI>0:${PORTSDIR}/databases/p5-DBI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Inspector.3 \
+ DBIx::Inspector::Column.3 \
+ DBIx::Inspector::ForeignKey.3 \
+ DBIx::Inspector::Iterator.3 \
+ DBIx::Inspector::Table.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Inspector/distinfo b/databases/p5-DBIx-Inspector/distinfo
new file mode 100644
index 000000000000..95d27fd36340
--- /dev/null
+++ b/databases/p5-DBIx-Inspector/distinfo
@@ -0,0 +1,2 @@
+SHA256 (DBIx-Inspector-0.04.tar.gz) = 8ba7c9fd2ef5b863b78f613319a4620828029d366ae7acb309a0e6e968296b50
+SIZE (DBIx-Inspector-0.04.tar.gz) = 25031
diff --git a/databases/p5-DBIx-Inspector/pkg-descr b/databases/p5-DBIx-Inspector/pkg-descr
new file mode 100644
index 000000000000..6a9a3c65dc47
--- /dev/null
+++ b/databases/p5-DBIx-Inspector/pkg-descr
@@ -0,0 +1,3 @@
+Get information from $dbh.
+
+WWW: http://search.cpan.org/dist/DBIx-Inspector/
diff --git a/databases/p5-DBIx-Inspector/pkg-plist b/databases/p5-DBIx-Inspector/pkg-plist
new file mode 100644
index 000000000000..010a98fefbc2
--- /dev/null
+++ b/databases/p5-DBIx-Inspector/pkg-plist
@@ -0,0 +1,19 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Inspector/.packlist
+%%SITE_PERL%%/DBIx/Inspector.pm
+%%SITE_PERL%%/DBIx/Inspector/Column.pm
+%%SITE_PERL%%/DBIx/Inspector/Driver/Base.pm
+%%SITE_PERL%%/DBIx/Inspector/Driver/Pg.pm
+%%SITE_PERL%%/DBIx/Inspector/Driver/SQLite.pm
+%%SITE_PERL%%/DBIx/Inspector/Driver/mysql.pm
+%%SITE_PERL%%/DBIx/Inspector/ForeignKey.pm
+%%SITE_PERL%%/DBIx/Inspector/ForeignKey/Pg.pm
+%%SITE_PERL%%/DBIx/Inspector/Iterator.pm
+%%SITE_PERL%%/DBIx/Inspector/Iterator/Null.pm
+%%SITE_PERL%%/DBIx/Inspector/Table.pm
+@dirrm %%SITE_PERL%%/DBIx/Inspector/Iterator
+@dirrm %%SITE_PERL%%/DBIx/Inspector/ForeignKey
+@dirrm %%SITE_PERL%%/DBIx/Inspector/Driver
+@dirrm %%SITE_PERL%%/DBIx/Inspector
+@dirrmtry %%SITE_PERL%%/DBIx
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Inspector
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx