aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Lite
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2017-03-03 06:24:05 +0000
committerWen Heping <wen@FreeBSD.org>2017-03-03 06:24:05 +0000
commit448056df001e6608ea61146e683aeba6594843ef (patch)
treee91b6693217f8479a8a36bad931c8636dce6a0a1 /databases/p5-DBIx-Lite
parent59a159ac83e3b3804d812914c51a1c8895cd1cce (diff)
downloadports-448056df001e6608ea61146e683aeba6594843ef.tar.gz
ports-448056df001e6608ea61146e683aeba6594843ef.zip
Notes
Diffstat (limited to 'databases/p5-DBIx-Lite')
-rw-r--r--databases/p5-DBIx-Lite/Makefile25
-rw-r--r--databases/p5-DBIx-Lite/distinfo3
-rw-r--r--databases/p5-DBIx-Lite/pkg-descr15
-rw-r--r--databases/p5-DBIx-Lite/pkg-plist10
4 files changed, 53 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Lite/Makefile b/databases/p5-DBIx-Lite/Makefile
new file mode 100644
index 000000000000..eb31719e97b9
--- /dev/null
+++ b/databases/p5-DBIx-Lite/Makefile
@@ -0,0 +1,25 @@
+# Created by: Wen Heping <wen@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= DBIx-Lite
+PORTVERSION= 0.31
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Chained and minimal ORM
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-DBIx-Connector>=0:databases/p5-DBIx-Connector \
+ p5-Data-Page>=0:databases/p5-Data-Page \
+ p5-SQL-Abstract-More>=0:databases/p5-SQL-Abstract-More
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-DBD-SQLite>=1.29:databases/p5-DBD-SQLite
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Lite/distinfo b/databases/p5-DBIx-Lite/distinfo
new file mode 100644
index 000000000000..3949cc66f92b
--- /dev/null
+++ b/databases/p5-DBIx-Lite/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1488506463
+SHA256 (DBIx-Lite-0.31.tar.gz) = a5a7892ff10e9bf4f3806d2fba31cd701017af8df8ea44de8b509a87c6dce9d0
+SIZE (DBIx-Lite-0.31.tar.gz) = 27288
diff --git a/databases/p5-DBIx-Lite/pkg-descr b/databases/p5-DBIx-Lite/pkg-descr
new file mode 100644
index 000000000000..58f31fec64f0
--- /dev/null
+++ b/databases/p5-DBIx-Lite/pkg-descr
@@ -0,0 +1,15 @@
+DBIx::Lite was written with some goals in mind, that no other
+available module provides. Such goals/key features are:
+
+no need to define your database schema (most features work without
+one and some advanced features only require some bits, and still
+not the full table definitions)
+no need to connect to database: the module can just generate SQL
+for you
+chained methods with lazy SQL generation
+joins/relationships
+optional custom classes for results and resultsets with custom methods
+SQL::Abstract syntax
+paging features (with Data::Page)
+
+WWW: http://search.cpan.org/dist/DBIx-Lite/
diff --git a/databases/p5-DBIx-Lite/pkg-plist b/databases/p5-DBIx-Lite/pkg-plist
new file mode 100644
index 000000000000..2a25752d6aea
--- /dev/null
+++ b/databases/p5-DBIx-Lite/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/DBIx/Lite.pm
+%%SITE_PERL%%/DBIx/Lite/ResultSet.pm
+%%SITE_PERL%%/DBIx/Lite/Row.pm
+%%SITE_PERL%%/DBIx/Lite/Schema.pm
+%%SITE_PERL%%/DBIx/Lite/Schema/Table.pm
+%%PERL5_MAN3%%/DBIx::Lite.3.gz
+%%PERL5_MAN3%%/DBIx::Lite::ResultSet.3.gz
+%%PERL5_MAN3%%/DBIx::Lite::Row.3.gz
+%%PERL5_MAN3%%/DBIx::Lite::Schema.3.gz
+%%PERL5_MAN3%%/DBIx::Lite::Schema::Table.3.gz