aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Recordset/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-08 12:01:23 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-08 12:01:23 +0000
commit70b473129c3b024954e117e5a7d1a0058da7656e (patch)
treee965d3935a2190f9c56f993a13b5fff33def1ddb /databases/p5-DBIx-Recordset/Makefile
parente4bc6a364b102c105d07a27c46e8bef16a52b9ae (diff)
add p5-DBIx-Recordset
Perl module for abstraction and simplification of database access PR: 26958 Submitted by: Sergey Skvortsov <skv@protey.ru>
Notes
Notes: svn path=/head/; revision=42404
Diffstat (limited to 'databases/p5-DBIx-Recordset/Makefile')
-rw-r--r--databases/p5-DBIx-Recordset/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Recordset/Makefile b/databases/p5-DBIx-Recordset/Makefile
new file mode 100644
index 000000000000..440270d72c7e
--- /dev/null
+++ b/databases/p5-DBIx-Recordset/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: DBIx::Recordset
+# Date created: 29 Apr 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Recordset
+PORTVERSION= 0.23
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= DBIx::Database.3 DBIx::Intrors.3 DBIx::Recordset::DBSeq.3 \
+ DBIx::Recordset::FileSeq.3 DBIx::Recordset.3 DBIx::Compat.3
+
+.include <bsd.port.mk>