aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-SQLEngine/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-08-08 14:21:02 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-08-08 14:21:02 +0000
commit972e4750dc689255da32281cb5d9f4c333f12514 (patch)
treefbc050de547c5dc1407155005369e0382b7dcd1d /databases/p5-DBIx-SQLEngine/Makefile
parent03ceb2a3e195fa3fea8c5a55c9a5dec278006174 (diff)
downloadports-972e4750dc689255da32281cb5d9f4c333f12514.tar.gz
ports-972e4750dc689255da32281cb5d9f4c333f12514.zip
Notes
Diffstat (limited to 'databases/p5-DBIx-SQLEngine/Makefile')
-rw-r--r--databases/p5-DBIx-SQLEngine/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/databases/p5-DBIx-SQLEngine/Makefile b/databases/p5-DBIx-SQLEngine/Makefile
new file mode 100644
index 000000000000..369f4dd17324
--- /dev/null
+++ b/databases/p5-DBIx-SQLEngine/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: DBIx::SQLEngine
+# Date created: 31.7.2003
+# Whom: Hansjoerg Pehofer <hansjoerg.pehofer@uibk.ac.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-SQLEngine
+PORTVERSION= 0.009
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hansjoerg.pehofer@uibk.ac.at
+COMMENT= Extends DBI with high-level operations
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/DBIx/AnyDBD.pm:${PORTSDIR}/databases/p5-DBIx-AnyDBD \
+ ${SITE_PERL}/Class/MakeMethods/Template.pm:${PORTSDIR}/devel/p5-Class-MakeMethods
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::SQLEngine::Criteria::StringEquality.3\
+ DBIx::Changes.3\
+ DBIx::SQLEngine::Criteria::Or.3\
+ DBIx::SQLEngine::Criteria::And.3\
+ DBIx::SQLEngine::ToDo.3\
+ DBIx::SQLEngine::ReadMe.3\
+ DBIx::SQLEngine::Criteria.3\
+ DBIx::SQLEngine::Criteria::Compound.3\
+ DBIx::SQLEngine::Criteria::NumericLesser.3\
+ DBIx::SQLEngine::Criteria::Comparison.3\
+ DBIx::SQLEngine::Criteria::Not.3\
+ DBIx::SQLEngine::Changes.3\
+ DBIx::SQLEngine::Criteria::LiteralSQL.3\
+ DBIx::SQLEngine::Mixin::SeqTable.3\
+ DBIx::SQLEngine.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>