aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Safe
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-12-05 11:44:19 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-12-05 11:44:19 +0000
commitdcb485b3240bb08a76c90d283c99e3d1d4b7f053 (patch)
tree83408043080388fa4397a191c2adce89dddc28be /databases/p5-DBIx-Safe
parentef0637a389283a0907971fafccc79f75beed49c1 (diff)
Notes
Diffstat (limited to 'databases/p5-DBIx-Safe')
-rw-r--r--databases/p5-DBIx-Safe/Makefile27
-rw-r--r--databases/p5-DBIx-Safe/distinfo2
-rw-r--r--databases/p5-DBIx-Safe/pkg-descr24
-rw-r--r--databases/p5-DBIx-Safe/pkg-plist5
4 files changed, 58 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Safe/Makefile b/databases/p5-DBIx-Safe/Makefile
new file mode 100644
index 000000000000..6da90a3771cf
--- /dev/null
+++ b/databases/p5-DBIx-Safe/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-DBIx-Safe
+# Date created: 2011-12-05
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Safe
+PORTVERSION= 1.2.5
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:TURNSTEP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Safer access to your database through a DBI database handle
+
+BUILD_DEPENDS= p5-DBD-Pg>=1.49:${PORTSDIR}/databases/p5-DBD-Pg \
+ p5-DBI>=1.490:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= p5-DBD-Pg>=1.49:${PORTSDIR}/databases/p5-DBD-Pg \
+ p5-DBI>=1.490:${PORTSDIR}/databases/p5-DBI
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Safe.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Safe/distinfo b/databases/p5-DBIx-Safe/distinfo
new file mode 100644
index 000000000000..bb959718910c
--- /dev/null
+++ b/databases/p5-DBIx-Safe/distinfo
@@ -0,0 +1,2 @@
+SHA256 (DBIx-Safe-1.2.5.tar.gz) = 73279fd98b20034d3735dee67e2b89ac63d55449c3c64dd1a7ba0df10fbe0acf
+SIZE (DBIx-Safe-1.2.5.tar.gz) = 16958
diff --git a/databases/p5-DBIx-Safe/pkg-descr b/databases/p5-DBIx-Safe/pkg-descr
new file mode 100644
index 000000000000..9c92c44153b1
--- /dev/null
+++ b/databases/p5-DBIx-Safe/pkg-descr
@@ -0,0 +1,24 @@
+The purpose of DBIx::Safe is to give controlled, limited access to an
+application, rather than simply passing it a raw database handle through DBI.
+DBIx::Safe acts as a wrapper to the database, by only allowing through the
+commands you tell it to. It filters all things related to the database handle -
+methods and attributes.
+
+The typical usage is for your application to create a database handle via a
+normal DBI call to new(), then pass that to DBIx::Safe->new(), which will return
+you a DBIx::Safe object. After specifying exactly what is and what is not
+allowed, you can pass the object to the untrusted application. The object will
+act very similar to a DBI database handle, and in most cases can be used
+interchangeably.
+
+By default, nothing is allowed to run at all. There are many things you can
+control. You can specify which SQL commands are allowed, by indicating the first
+word in the SQL statement (e.g. 'SELECT'). You can specify which database
+methods are allowed to run (e.g. 'ping'). You can specify a regular expression
+that allows matching SQL statements to run (e.g. 'qr{SET TIMEZONE}'). You can
+specify a regular expression that is NOT allowed to run (e.g. qr(UPDATE xxx}).
+Finally, you can indicate which database attributes are allowed to be read and
+changed (e.g. 'PrintError'). For all of the above, there are matching methods to
+remove them as well.
+
+WWW: http://search.cpan.org/dist/DBIx-Safe/
diff --git a/databases/p5-DBIx-Safe/pkg-plist b/databases/p5-DBIx-Safe/pkg-plist
new file mode 100644
index 000000000000..e06c02fe1f98
--- /dev/null
+++ b/databases/p5-DBIx-Safe/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/DBIx/Safe.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Safe/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Safe
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx
+@dirrmtry %%SITE_PERL%%/DBIx