aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-SearchBuilder
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-09-16 05:43:52 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-09-16 05:43:52 +0000
commit6b470bae86247b8cb79b0dc6e43078df2f84c4ae (patch)
treee1545740f8801646e19c181252cb4c4e39df9ca8 /databases/p5-DBIx-SearchBuilder
parentb63d72fe5f0a821fa729c344f9b44de714603abc (diff)
downloadports-6b470bae86247b8cb79b0dc6e43078df2f84c4ae.tar.gz
ports-6b470bae86247b8cb79b0dc6e43078df2f84c4ae.zip
Notes
Diffstat (limited to 'databases/p5-DBIx-SearchBuilder')
-rw-r--r--databases/p5-DBIx-SearchBuilder/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/databases/p5-DBIx-SearchBuilder/Makefile b/databases/p5-DBIx-SearchBuilder/Makefile
index 160f2a29a166..59ad3a698b7d 100644
--- a/databases/p5-DBIx-SearchBuilder/Makefile
+++ b/databases/p5-DBIx-SearchBuilder/Makefile
@@ -15,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Perl extension for easy SQL SELECT Statement generation
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${SITE_PERL}/Class/ReturnValue.pm:${PORTSDIR}/devel/p5-Class-ReturnValue
+BUILD_DEPENDS= ${SITE_PERL}/Class/ReturnValue.pm:${PORTSDIR}/devel/p5-Class-ReturnValue
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -27,4 +26,14 @@ MAN3= DBIx::SearchBuilder.3 DBIx::SearchBuilder::Handle.3 \
DBIx::SearchBuilder::Handle::mysqlPP.3 \
DBIx::SearchBuilder::Record.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
+.else
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+.endif
+
+.include <bsd.port.post.mk>