aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Sequence
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-01-06 07:06:46 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-01-06 07:06:46 +0000
commitc3f93965a957a722f2bf307396406d46d13253a6 (patch)
tree1a06ce5334d8349e676e498704585a19a8f7cf22 /databases/p5-DBIx-Sequence
parent95d44309044b6f9ccfbf028ac5a6d9dc7c94ae8f (diff)
downloadports-c3f93965a957a722f2bf307396406d46d13253a6.tar.gz
ports-c3f93965a957a722f2bf307396406d46d13253a6.zip
Notes
Diffstat (limited to 'databases/p5-DBIx-Sequence')
-rw-r--r--databases/p5-DBIx-Sequence/Makefile24
-rw-r--r--databases/p5-DBIx-Sequence/distinfo3
-rw-r--r--databases/p5-DBIx-Sequence/pkg-descr15
-rw-r--r--databases/p5-DBIx-Sequence/pkg-plist8
4 files changed, 50 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Sequence/Makefile b/databases/p5-DBIx-Sequence/Makefile
new file mode 100644
index 000000000000..2b3cc389a69b
--- /dev/null
+++ b/databases/p5-DBIx-Sequence/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-DBIx-Sequence
+# Date created: 6 Jan 2006
+# Whom: Jon Nistor <nistor@snickers.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Sequence
+PORTVERSION= 1.5
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DBIx
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= nistor@snickers.org
+COMMENT= DBIx::Sequence - A simple SQL92 ID generator
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Sequence.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-DBIx-Sequence/distinfo b/databases/p5-DBIx-Sequence/distinfo
new file mode 100644
index 000000000000..463886b67898
--- /dev/null
+++ b/databases/p5-DBIx-Sequence/distinfo
@@ -0,0 +1,3 @@
+MD5 (DBIx-Sequence-1.5.tar.gz) = 177e5c5efc7c04613de7cd1f5fe0186a
+SHA256 (DBIx-Sequence-1.5.tar.gz) = 7fccc5a35792bcc1ae302af916f1ead04a1a76f7cc6a0d48fb6443a40bd7bcc7
+SIZE (DBIx-Sequence-1.5.tar.gz) = 12423
diff --git a/databases/p5-DBIx-Sequence/pkg-descr b/databases/p5-DBIx-Sequence/pkg-descr
new file mode 100644
index 000000000000..3425f83edb36
--- /dev/null
+++ b/databases/p5-DBIx-Sequence/pkg-descr
@@ -0,0 +1,15 @@
+DBIx::Sequence - A simple SQL92 ID generator
+
+his module is intended to give easier portability to Perl database
+application by providing a database independant unique ID generator.
+This way, an application developer is not bound to use his database's
+SEQUENCE or auto_increment thus making his application portable on
+multiple database environnements.
+
+This module implements a simple Spin Locker mechanism and is garanteed
+to return a unique value every time it is called, even with concurrent
+processes. It uses your database for its state storage with ANSI SQL92
+compliant SQL. All SQL queries inside DBIx::Sequence are pre cached and
+very efficient especially under mod_perl.
+
+WWW: http://search.cpan.org/dist/DBIx-Sequence/
diff --git a/databases/p5-DBIx-Sequence/pkg-plist b/databases/p5-DBIx-Sequence/pkg-plist
new file mode 100644
index 000000000000..b0947422bb6b
--- /dev/null
+++ b/databases/p5-DBIx-Sequence/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/DBIx/Sequence.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Sequence/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Sequence
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx/Sequence 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBIx 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DBIx/Sequence 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DBIx 2>/dev/null || true