aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-DBIx-Sunny/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2011-10-18 08:06:47 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2011-10-18 08:06:47 +0000
commitce607b59425d198d6b5bdc1f1b1fb9d007d64a23 (patch)
treef6db00f8904d815c4809d76dec3e502490b966f7 /databases/p5-DBIx-Sunny/Makefile
parent5920fe2b262252f1c46add4dea2e34195097e579 (diff)
Notes
Diffstat (limited to 'databases/p5-DBIx-Sunny/Makefile')
-rw-r--r--databases/p5-DBIx-Sunny/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Sunny/Makefile b/databases/p5-DBIx-Sunny/Makefile
new file mode 100644
index 000000000000..9f45a3d04e46
--- /dev/null
+++ b/databases/p5-DBIx-Sunny/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: DBIx::Sunny
+# Date created: 18 October 2011
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Sunny
+PORTVERSION= 0.14
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= A simple DBI wrapper supports SQLite and MySQL
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-DBI>=1.615:${PORTSDIR}/databases/p5-DBI \
+ p5-Capture-Tiny>=0:${PORTSDIR}/devel/p5-Capture-Tiny \
+ p5-Class-Accessor-Lite>=0.05:${PORTSDIR}/devel/p5-Class-Accessor-Lite \
+ p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ p5-DBIx-TransactionManager>=0:${PORTSDIR}/databases/p5-DBIx-TransactionManager \
+ p5-Data-Validator>=0:${PORTSDIR}/devel/p5-Data-Validator
+RUN_DEPENDS= p5-DBI>=1.615:${PORTSDIR}/databases/p5-DBI \
+ p5-Class-Accessor-Lite>=0.05:${PORTSDIR}/devel/p5-Class-Accessor-Lite \
+ p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ p5-DBIx-TransactionManager>=0:${PORTSDIR}/databases/p5-DBIx-TransactionManager \
+ p5-Data-Validator>=0:${PORTSDIR}/devel/p5-Data-Validator
+
+TEST_DEPENDS= p5-DBD-SQLite>=1.27:${PORTSDIR}/databases/p5-DBD-SQLite \
+ p5-Capture-Tiny>=0:${PORTSDIR}/devel/p5-Capture-Tiny
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Sunny.3 \
+ DBIx::Sunny::Schema.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+
+BUILD_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+.endif
+
+.include <bsd.port.post.mk>