aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Exception-Class-DBI
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-10-20 20:46:41 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-10-20 20:46:41 +0000
commit9909d8c4e72f3bbe5aa46d150add5688479c6b1a (patch)
treeb56df1307c0c7a64afd637d2a8fcae0b6877bfbb /databases/p5-Exception-Class-DBI
parent735d21c741548a58009aade16908451ad9046acc (diff)
downloadports-9909d8c4e72f3bbe5aa46d150add5688479c6b1a.tar.gz
ports-9909d8c4e72f3bbe5aa46d150add5688479c6b1a.zip
Notes
Diffstat (limited to 'databases/p5-Exception-Class-DBI')
-rw-r--r--databases/p5-Exception-Class-DBI/Makefile26
-rw-r--r--databases/p5-Exception-Class-DBI/distinfo2
-rw-r--r--databases/p5-Exception-Class-DBI/pkg-descr8
-rw-r--r--databases/p5-Exception-Class-DBI/pkg-plist3
4 files changed, 39 insertions, 0 deletions
diff --git a/databases/p5-Exception-Class-DBI/Makefile b/databases/p5-Exception-Class-DBI/Makefile
new file mode 100644
index 000000000000..89d9b76e5ecc
--- /dev/null
+++ b/databases/p5-Exception-Class-DBI/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Exception-Class
+# Date created: 15 October 2005
+# Whom: Rod Taylor <ports@rbt.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Exception-Class-DBI
+PORTVERSION= 0.92
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Exception
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@rbt.ca
+COMMENT= DBI Exception objects
+
+BUILD_DEPENDS= ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Exception::Class::DBI.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-Exception-Class-DBI/distinfo b/databases/p5-Exception-Class-DBI/distinfo
new file mode 100644
index 000000000000..e0c77db96cf7
--- /dev/null
+++ b/databases/p5-Exception-Class-DBI/distinfo
@@ -0,0 +1,2 @@
+MD5 (Exception-Class-DBI-0.92.tar.gz) = 7b8032fdf31ccab88d19d1446c6fe741
+SIZE (Exception-Class-DBI-0.92.tar.gz) = 10056
diff --git a/databases/p5-Exception-Class-DBI/pkg-descr b/databases/p5-Exception-Class-DBI/pkg-descr
new file mode 100644
index 000000000000..c146e99b08d3
--- /dev/null
+++ b/databases/p5-Exception-Class-DBI/pkg-descr
@@ -0,0 +1,8 @@
+This module offers a set of DBI-specific exception classes. They
+inherit from Exception::Class, the base class for all exception
+objects created by the Exception::Class module from the CPAN.
+Exception::Class::DBI itself offers a single class method, handler(),
+that returns a code reference appropriate for passing to the DBI
+HandleError attribute.
+
+WWW: http://search.cpan.org/dist/Exception-Class-DBI/
diff --git a/databases/p5-Exception-Class-DBI/pkg-plist b/databases/p5-Exception-Class-DBI/pkg-plist
new file mode 100644
index 000000000000..d99543c47bf1
--- /dev/null
+++ b/databases/p5-Exception-Class-DBI/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Exception/Class/DBI.pm
+@unexec rmdir %D/%%%SITE_PERL%%/Exception/Class 2>/dev/null || true
+@unexec rmdir %D/%%%SITE_PERL%%/Exception 2>/dev/null || true