aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-LMDB_File
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2015-06-18 02:06:36 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2015-06-18 02:06:36 +0000
commitfef7d4aa3010fe5cbf313864cdb5ba02d7b9a659 (patch)
treea9c0dc439dffb5a145ae319f0c0c1ec83caf1511 /databases/p5-LMDB_File
parent19daca82abc0946d0c0b2505d966d25391b2d577 (diff)
Notes
Diffstat (limited to 'databases/p5-LMDB_File')
-rw-r--r--databases/p5-LMDB_File/Makefile22
-rw-r--r--databases/p5-LMDB_File/distinfo2
-rw-r--r--databases/p5-LMDB_File/files/patch-liblmdb_Makefile16
-rw-r--r--databases/p5-LMDB_File/pkg-descr11
-rw-r--r--databases/p5-LMDB_File/pkg-plist4
5 files changed, 55 insertions, 0 deletions
diff --git a/databases/p5-LMDB_File/Makefile b/databases/p5-LMDB_File/Makefile
new file mode 100644
index 000000000000..b5f08c1aad34
--- /dev/null
+++ b/databases/p5-LMDB_File/Makefile
@@ -0,0 +1,22 @@
+# Created by: vanilla@
+# $FreeBSD$
+
+PORTNAME= LMDB_File
+PORTVERSION= 0.05
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= Perl wrapper around the OpenLDAP's LMDB
+
+LICENSE= ART20
+
+CFLAGS+= -DMDB_DSYNC=O_SYNC -Dfdatasync=fsync
+USES= perl5
+USE_PERL5= configure
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/LMDB_File/LMDB_File.so
+
+.include <bsd.port.mk>
diff --git a/databases/p5-LMDB_File/distinfo b/databases/p5-LMDB_File/distinfo
new file mode 100644
index 000000000000..ad232d0c2e3e
--- /dev/null
+++ b/databases/p5-LMDB_File/distinfo
@@ -0,0 +1,2 @@
+SHA256 (LMDB_File-0.05.tar.gz) = ea78115bd78a3ff740b91d74e2d18773a98f72274a6761f7e2ea94d765161331
+SIZE (LMDB_File-0.05.tar.gz) = 190963
diff --git a/databases/p5-LMDB_File/files/patch-liblmdb_Makefile b/databases/p5-LMDB_File/files/patch-liblmdb_Makefile
new file mode 100644
index 000000000000..4511ae16f48e
--- /dev/null
+++ b/databases/p5-LMDB_File/files/patch-liblmdb_Makefile
@@ -0,0 +1,16 @@
+--- liblmdb/Makefile.orig 2013-09-11 05:23:43 UTC
++++ liblmdb/Makefile
+@@ -16,11 +16,11 @@
+ # There may be other macros in mdb.c of interest. You should
+ # read mdb.c before changing any of them.
+ #
+-CC = gcc
++CC ?= gcc
+ W = -W -Wall -Wno-unused-parameter -Wbad-function-cast
+ THREADS = -pthread
+ OPT = -O2 -g
+-CFLAGS = $(THREADS) $(OPT) $(W) $(XCFLAGS)
++CFLAGS += $(THREADS) $(OPT) $(W) $(XCFLAGS)
+ LDLIBS =
+ SOLIBS =
+ prefix = /usr/local
diff --git a/databases/p5-LMDB_File/pkg-descr b/databases/p5-LMDB_File/pkg-descr
new file mode 100644
index 000000000000..19f20522ca5a
--- /dev/null
+++ b/databases/p5-LMDB_File/pkg-descr
@@ -0,0 +1,11 @@
+LMDB_File is a Perl wrapper around the OpenLDAP's LMDB (Lightning
+Memory-Mapped Database) C library.
+
+LMDB is an ultra-fast, ultra-compact key-value data store developed
+by Symas for the OpenLDAP Project. See http://symas.com/mdb/ for details.
+
+LMDB_File provides full access to the complete C API, a thin Perl wrapper
+with an Object-Oriented interface and a simple Perl's tie interface
+compatible with others DBMs.
+
+WWW: http://search.cpan.org/dist/LMDB_File/
diff --git a/databases/p5-LMDB_File/pkg-plist b/databases/p5-LMDB_File/pkg-plist
new file mode 100644
index 000000000000..1e43e338774b
--- /dev/null
+++ b/databases/p5-LMDB_File/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_ARCH%%/LMDB_File.pm
+%%SITE_ARCH%%/auto/LMDB_File/LMDB_File.so
+%%SITE_ARCH%%/auto/LMDB_File/autosplit.ix
+%%PERL5_MAN3%%/LMDB_File.3.gz