aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Net-Async-CassandraCQL/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-08-28 14:07:07 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-08-28 14:07:07 +0000
commite539e96c796b2aff8ce2c13128dabd285fed8b53 (patch)
tree8db1815dd6c2439f1f1e5388d237261a2c9c1477 /databases/p5-Net-Async-CassandraCQL/Makefile
parentd38c7c094a7f2ce7147451498a7f06600941b6d6 (diff)
Notes
Diffstat (limited to 'databases/p5-Net-Async-CassandraCQL/Makefile')
-rw-r--r--databases/p5-Net-Async-CassandraCQL/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/databases/p5-Net-Async-CassandraCQL/Makefile b/databases/p5-Net-Async-CassandraCQL/Makefile
new file mode 100644
index 000000000000..fcd358b72141
--- /dev/null
+++ b/databases/p5-Net-Async-CassandraCQL/Makefile
@@ -0,0 +1,31 @@
+# Created by: Denis Shaposhnikov <dsh@bamus.cz>
+# $FreeBSD$
+
+PORTNAME= Net-Async-CassandraCQL
+PORTVERSION= 0.11
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= admins@perceptyx.com
+COMMENT= Use Cassandra databases with IO::Async using CQL
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Compress-Snappy>0:${PORTSDIR}/archivers/p5-Compress-Snappy \
+ devel/p5-Devel-GlobalDestruction>0:${PORTSDIR}/devel/p5-Devel-GlobalDestruction \
+ p5-Future>0:${PORTSDIR}/devel/p5-Future \
+ p5-IO-Async>0:${PORTSDIR}/devel/p5-IO-Async \
+ p5-IO-Socket-IP>0:${PORTSDIR}/net/p5-IO-Socket-IP \
+ p5-Test-Identity>0:${PORTSDIR}/devel/p5-Test-Identity \
+ p5-Test-Refcount>0:${PORTSDIR}/devel/p5-Test-Refcount \
+ p5-Compress-LZ4>0:${PORTSDIR}/archivers/p5-Compress-LZ4 \
+ p5-Protocol-CassandraCQL>0:${PORTSDIR}/databases/p5-Protocol-CassandraCQL
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>