aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Net-Async-CassandraCQL
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-08-28 14:07:07 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-08-28 14:07:07 +0000
commite539e96c796b2aff8ce2c13128dabd285fed8b53 (patch)
tree8db1815dd6c2439f1f1e5388d237261a2c9c1477 /databases/p5-Net-Async-CassandraCQL
parentd38c7c094a7f2ce7147451498a7f06600941b6d6 (diff)
New port: databases/p5-Net-Async-CassandraCQL
This module allows use of the CQL3 interface of a Cassandra database. It fully supports asynchronous operation via IO::Async, allowing both direct queries and prepared statements to be managed concurrently, if required. Alternatively, as the interface is entirely based on Future objects, it can be operated synchronously in a blocking fashion by simply awaiting each individual operation by calling the get method. WWW: http://search.cpan.org/dist/Net-Async-CassandraCQL/ PR: 186057 Submitted by: admins@perceptyx.com
Notes
Notes: svn path=/head/; revision=366405
Diffstat (limited to 'databases/p5-Net-Async-CassandraCQL')
-rw-r--r--databases/p5-Net-Async-CassandraCQL/Makefile31
-rw-r--r--databases/p5-Net-Async-CassandraCQL/distinfo2
-rw-r--r--databases/p5-Net-Async-CassandraCQL/pkg-descr9
-rw-r--r--databases/p5-Net-Async-CassandraCQL/pkg-plist13
4 files changed, 55 insertions, 0 deletions
diff --git a/databases/p5-Net-Async-CassandraCQL/Makefile b/databases/p5-Net-Async-CassandraCQL/Makefile
new file mode 100644
index 000000000000..fcd358b72141
--- /dev/null
+++ b/databases/p5-Net-Async-CassandraCQL/Makefile
@@ -0,0 +1,31 @@
+# Created by: Denis Shaposhnikov <dsh@bamus.cz>
+# $FreeBSD$
+
+PORTNAME= Net-Async-CassandraCQL
+PORTVERSION= 0.11
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= admins@perceptyx.com
+COMMENT= Use Cassandra databases with IO::Async using CQL
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Compress-Snappy>0:${PORTSDIR}/archivers/p5-Compress-Snappy \
+ devel/p5-Devel-GlobalDestruction>0:${PORTSDIR}/devel/p5-Devel-GlobalDestruction \
+ p5-Future>0:${PORTSDIR}/devel/p5-Future \
+ p5-IO-Async>0:${PORTSDIR}/devel/p5-IO-Async \
+ p5-IO-Socket-IP>0:${PORTSDIR}/net/p5-IO-Socket-IP \
+ p5-Test-Identity>0:${PORTSDIR}/devel/p5-Test-Identity \
+ p5-Test-Refcount>0:${PORTSDIR}/devel/p5-Test-Refcount \
+ p5-Compress-LZ4>0:${PORTSDIR}/archivers/p5-Compress-LZ4 \
+ p5-Protocol-CassandraCQL>0:${PORTSDIR}/databases/p5-Protocol-CassandraCQL
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/databases/p5-Net-Async-CassandraCQL/distinfo b/databases/p5-Net-Async-CassandraCQL/distinfo
new file mode 100644
index 000000000000..06ae2011a838
--- /dev/null
+++ b/databases/p5-Net-Async-CassandraCQL/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-Async-CassandraCQL-0.11.tar.gz) = 92b758ab2ff66a726eca423771787a5afb4c5c15031f5da6afeae68e1df2aee0
+SIZE (Net-Async-CassandraCQL-0.11.tar.gz) = 45237
diff --git a/databases/p5-Net-Async-CassandraCQL/pkg-descr b/databases/p5-Net-Async-CassandraCQL/pkg-descr
new file mode 100644
index 000000000000..bac82d2666cf
--- /dev/null
+++ b/databases/p5-Net-Async-CassandraCQL/pkg-descr
@@ -0,0 +1,9 @@
+This module allows use of the CQL3 interface of a Cassandra
+database. It fully supports asynchronous operation via IO::Async,
+allowing both direct queries and prepared statements to be managed
+concurrently, if required. Alternatively, as the interface is entirely
+based on Future objects, it can be operated synchronously in a
+blocking fashion by simply awaiting each individual operation by
+calling the get method.
+
+WWW: http://search.cpan.org/dist/Net-Async-CassandraCQL/
diff --git a/databases/p5-Net-Async-CassandraCQL/pkg-plist b/databases/p5-Net-Async-CassandraCQL/pkg-plist
new file mode 100644
index 000000000000..555165c15f0b
--- /dev/null
+++ b/databases/p5-Net-Async-CassandraCQL/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/Net/Async/CassandraCQL.pm
+%%SITE_PERL%%/Net/Async/CassandraCQL/Connection.pm
+%%SITE_PERL%%/Net/Async/CassandraCQL/Query.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Async/CassandraCQL/.packlist
+%%PERL5_MAN3%%/Net::Async::CassandraCQL.3.gz
+%%PERL5_MAN3%%/Net::Async::CassandraCQL::Connection.3.gz
+%%PERL5_MAN3%%/Net::Async::CassandraCQL::Query.3.gz
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Async/CassandraCQL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Async
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/Async/CassandraCQL
+@dirrmtry %%SITE_PERL%%/Net/Async
+@dirrmtry %%SITE_PERL%%/Net