aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-POE-Component-DBIAgent/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-13 12:30:13 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-13 12:30:13 +0000
commit6a003de971477a3b521f9ec0717971e25e60ea88 (patch)
tree782253d3de2628e05d6e9d3ac62ff0153d7a2b74 /databases/p5-POE-Component-DBIAgent/Makefile
parent0d6d4c4b0f1a92de244cbe36d88e58a40c4d9cef (diff)
downloadports-6a003de971477a3b521f9ec0717971e25e60ea88.tar.gz
ports-6a003de971477a3b521f9ec0717971e25e60ea88.zip
Notes
Diffstat (limited to 'databases/p5-POE-Component-DBIAgent/Makefile')
-rw-r--r--databases/p5-POE-Component-DBIAgent/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/databases/p5-POE-Component-DBIAgent/Makefile b/databases/p5-POE-Component-DBIAgent/Makefile
new file mode 100644
index 000000000000..46412a7f8386
--- /dev/null
+++ b/databases/p5-POE-Component-DBIAgent/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: POE-Component-DBIAgent
+# Date created: 10 Dec 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-DBIAgent
+PORTVERSION= 0.11
+CATEGORIES= devel perl5 databases
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= POE::Component::DBIAgent.3 POE::Component::DBIAgent::Helper.3 \
+ POE::Component::DBIAgent::Queue.3
+
+.include <bsd.port.mk>