aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Rose-DB/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-06-10 10:46:49 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-06-10 10:46:49 +0000
commitcf69935f05a4e5e41806fc896169a535939303ee (patch)
treeefbf12c5cd86bf41a7062ed43aeb1a60c5cc222c /databases/p5-Rose-DB/Makefile
parent083858b3259dd06b20b3b7fb4f65cc8aa838651b (diff)
downloadports-cf69935f05a4e5e41806fc896169a535939303ee.tar.gz
ports-cf69935f05a4e5e41806fc896169a535939303ee.zip
Notes
Diffstat (limited to 'databases/p5-Rose-DB/Makefile')
-rw-r--r--databases/p5-Rose-DB/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/databases/p5-Rose-DB/Makefile b/databases/p5-Rose-DB/Makefile
new file mode 100644
index 000000000000..a729c5a489aa
--- /dev/null
+++ b/databases/p5-Rose-DB/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: databases/p5-Rose-DB
+# Date created: 09 June 2006
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Rose-DB
+PORTVERSION= 0.673
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Rose
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= A DBI wrapper and abstraction layer
+
+BUILD_DEPENDS= ${SITE_PERL}/Rose/DateTime/Util.pm:${PORTSDIR}/devel/p5-Rose-DateTime \
+ ${SITE_PERL}/${PERL_ARCH}/Bit/Vector/Overload.pm:${PORTSDIR}/math/p5-Bit-Vector \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/DateTime/Format/MySQL.pm:${PORTSDIR}/devel/p5-DateTime-Format-MySQL \
+ ${SITE_PERL}/DateTime/Format/Pg.pm:${PORTSDIR}/devel/p5-DateTime-Format-Pg
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Rose::DB.3 \
+ Rose::DB::Constants.3 \
+ Rose::DB::Generic.3 \
+ Rose::DB::Informix.3 \
+ Rose::DB::MySQL.3 \
+ Rose::DB::Oracle.3 \
+ Rose::DB::Pg.3 \
+ Rose::DB::Registry.3 \
+ Rose::DB::Registry::Entry.3 \
+ Rose::DB::SQLite.3 \
+ Rose::DB::Tutorial.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>