aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-SQL-Interp
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2008-01-16 12:42:56 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2008-01-16 12:42:56 +0000
commit1baf0aca01252e827b00c2965d9c7c036413dc37 (patch)
treee1bd2f325aff80b8c0218e5f1feba3703024cf96 /databases/p5-SQL-Interp
parent3608a296acb98532cae3913064e861234718d337 (diff)
downloadports-1baf0aca01252e827b00c2965d9c7c036413dc37.tar.gz
ports-1baf0aca01252e827b00c2965d9c7c036413dc37.zip
Notes
Diffstat (limited to 'databases/p5-SQL-Interp')
-rw-r--r--databases/p5-SQL-Interp/Makefile23
-rw-r--r--databases/p5-SQL-Interp/distinfo3
-rw-r--r--databases/p5-SQL-Interp/pkg-descr15
-rw-r--r--databases/p5-SQL-Interp/pkg-plist7
4 files changed, 48 insertions, 0 deletions
diff --git a/databases/p5-SQL-Interp/Makefile b/databases/p5-SQL-Interp/Makefile
new file mode 100644
index 000000000000..6c61a5695c80
--- /dev/null
+++ b/databases/p5-SQL-Interp/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: SQL-Interp
+# Date created: 16 Jan 2008
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SQL-Interp
+PORTVERSION= 1.06
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Interpolate Perl variables into SQL with DBI
+
+RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Interp.3 SQL::Interp.3
+
+.include <bsd.port.mk>
diff --git a/databases/p5-SQL-Interp/distinfo b/databases/p5-SQL-Interp/distinfo
new file mode 100644
index 000000000000..fa29be6fa267
--- /dev/null
+++ b/databases/p5-SQL-Interp/distinfo
@@ -0,0 +1,3 @@
+MD5 (SQL-Interp-1.06.tar.gz) = 3f6921977e49a7e0942c09fa8dda00fe
+SHA256 (SQL-Interp-1.06.tar.gz) = 130ef97e309f00d75a057ecb0c4c3ca56ab996b1d763e79921ee7c401bb44cf1
+SIZE (SQL-Interp-1.06.tar.gz) = 36211
diff --git a/databases/p5-SQL-Interp/pkg-descr b/databases/p5-SQL-Interp/pkg-descr
new file mode 100644
index 000000000000..a25cffb1e6c8
--- /dev/null
+++ b/databases/p5-SQL-Interp/pkg-descr
@@ -0,0 +1,15 @@
+SQL::Interp converts a list of intermixed SQL fragments and
+variable references into a conventional SQL string and list
+of bind values suitable for passing onto DBI. This simple
+technique creates database calls that are simpler to create
+and easier to read, while still giving you full access to
+custom SQL.
+
+SQL::Interp properly binds or escapes variables. This recommended
+practice safeguards against "SQL injection" attacks. The DBI
+documentation has several links on the topic.
+
+Besides the simple techniques shown above, The SQL-Interpolate
+distribution includes the optional DBIx::Interp module.
+
+WWW: http://search.cpan.org/dist/SQL-Interp/
diff --git a/databases/p5-SQL-Interp/pkg-plist b/databases/p5-SQL-Interp/pkg-plist
new file mode 100644
index 000000000000..310509b729fa
--- /dev/null
+++ b/databases/p5-SQL-Interp/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SQL/Interp/.packlist
+%%SITE_PERL%%/DBIx/Interp.pm
+%%SITE_PERL%%/SQL/Interp.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/SQL/Interp
+@dirrmtry %%SITE_PERL%%/SQL
+@dirrmtry %%SITE_PERL%%/DBIx
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SQL