aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-T2/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-03-21 01:48:02 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-03-21 01:48:02 +0000
commit4b6bb91e63406e7a6834a419ed2a102ea09c0b25 (patch)
treeeca1a1f9affe332d33002c27702e0c15a09093a6 /databases/p5-T2/Makefile
parent1d2a866385831e1cd156e7dfa50edb7deede4833 (diff)
downloadports-4b6bb91e63406e7a6834a419ed2a102ea09c0b25.tar.gz
ports-4b6bb91e63406e7a6834a419ed2a102ea09c0b25.zip
Notes
Diffstat (limited to 'databases/p5-T2/Makefile')
-rw-r--r--databases/p5-T2/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/databases/p5-T2/Makefile b/databases/p5-T2/Makefile
new file mode 100644
index 000000000000..4cc32c9ee250
--- /dev/null
+++ b/databases/p5-T2/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-T2
+# Date created: 19 January 2004
+# Whom: Scott McWhirter <scott@surreytech.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= T2
+PORTVERSION= 0.07
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tangram/SAMV
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= scott@surreytech.co.uk
+COMMENT= Object Relational mapping system
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Set/Object.pm:${PORTSDIR}/devel/p5-Set-Object \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/Tangram.pm:${PORTSDIR}/databases/p5-Tangram \
+ ${SITE_PERL}/Class/Tangram.pm:${PORTSDIR}/devel/p5-Class-Tangram
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= T2.3 T2::Association.3 T2::Attribute.3 T2::Class.3 \
+ T2::Schema.3 T2::Storage.3
+
+.include <bsd.port.mk>