aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-Test-DatabaseRow/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-06-07 10:44:40 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-06-07 10:44:40 +0000
commit4a1c0ea7a29e518fe7777b592d0b11c296aa469d (patch)
tree78628504562d837337d10b91d44dd333396460cc /databases/p5-Test-DatabaseRow/Makefile
parentf07758714f3f72c5fcea2189c3bfd7b9255e9b97 (diff)
downloadports-4a1c0ea7a29e518fe7777b592d0b11c296aa469d.tar.gz
ports-4a1c0ea7a29e518fe7777b592d0b11c296aa469d.zip
Notes
Diffstat (limited to 'databases/p5-Test-DatabaseRow/Makefile')
-rw-r--r--databases/p5-Test-DatabaseRow/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/databases/p5-Test-DatabaseRow/Makefile b/databases/p5-Test-DatabaseRow/Makefile
new file mode 100644
index 000000000000..568a1ab31337
--- /dev/null
+++ b/databases/p5-Test-DatabaseRow/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Test-DatabaseRow
+# Date created: June 3 2006
+# Whom: Joshua D. Abraham <jabra@ccs.neu.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-DatabaseRow
+PORTVERSION= 1.04
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/M/MA/MARKF
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jabra@ccs.neu.edu
+COMMENT= Simple database tests
+
+BUILD_DEPENDS= ${SITE_PERL}/mach/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/Test/Builder/Module.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::DatabaseRow.3
+
+post-configure:
+ @${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or higher. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>