aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-postgresql-plperl/Makefile
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2003-09-04 12:47:47 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2003-09-04 12:47:47 +0000
commit9174a90a077724e9f8df2352efc764a91c94218d (patch)
tree7dc04a1e22f02971a90727039c562283f7fbeaf7 /databases/p5-postgresql-plperl/Makefile
parent20a71225064b096a90b0e2f127cacfbd4c81f4fe (diff)
Notes
Diffstat (limited to 'databases/p5-postgresql-plperl/Makefile')
-rw-r--r--databases/p5-postgresql-plperl/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/databases/p5-postgresql-plperl/Makefile b/databases/p5-postgresql-plperl/Makefile
index de7fb1073cc5..2bed2b63cdb6 100644
--- a/databases/p5-postgresql-plperl/Makefile
+++ b/databases/p5-postgresql-plperl/Makefile
@@ -4,22 +4,29 @@
#
# $FreeBSD$
#
+POSTGRESQL_PORT?= databases/postgresql7
-PORTNAME= postgresql-plperl
+PORTNAME= postgresql
+PORTVERSION!= cd ${.CURDIR}/../../${POSTGRESQL_PORT} && ${MAKE} -V PORTVERSION
+PORTREVISION?= 1
CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PGSQL}
+MASTER_SITE_SUBDIR!= cd ${.CURDIR}/../../${POSTGRESQL_PORT} && ${MAKE} -V MASTER_SITE_SUBDIR
PKGNAMEPREFIX= p5-
-PORTREVISION= 0
+PKGNAMESUFFIX= -plperl
+DISTFILES!= cd ${.CURDIR}/../../${POSTGRESQL_PORT} && ${MAKE} -V DISTFILES
+DIST_SUBDIR= postgresql
MAINTAINER= girgen@pingpong.net
COMMENT= A module for using Perl5 to write SQL functions
-POSTGRESQL_PORT?= databases/postgresql7
-POSTGRESQL_SUBPORT=YES
-.include "../../${POSTGRESQL_PORT}/Makefile"
-
RUN_DEPENDS= postgres:${PORTSDIR}/${POSTGRESQL_PORT}
+MD5_FILE= ${.CURDIR}/../../${POSTGRESQL_PORT}/distinfo
+
+USE_GMAKE= yes
USE_PERL5= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-perl
MAKE_ARGS+= -C src/pl/plperl