aboutsummaryrefslogtreecommitdiff
path: root/databases/p5-tokyotyrant/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-02-17 03:57:40 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-02-17 03:57:40 +0000
commit7dd996b47d7077a1399e4a45c1c9d86dc2885664 (patch)
treebd064855a34ede7fbb80f1ef25b392973742939c /databases/p5-tokyotyrant/Makefile
parent8379c973c9f5e00a06366396f46717560f8e35d2 (diff)
downloadports-7dd996b47d7077a1399e4a45c1c9d86dc2885664.tar.gz
ports-7dd996b47d7077a1399e4a45c1c9d86dc2885664.zip
Notes
Diffstat (limited to 'databases/p5-tokyotyrant/Makefile')
-rw-r--r--databases/p5-tokyotyrant/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/databases/p5-tokyotyrant/Makefile b/databases/p5-tokyotyrant/Makefile
new file mode 100644
index 000000000000..843b8a36ea3f
--- /dev/null
+++ b/databases/p5-tokyotyrant/Makefile
@@ -0,0 +1,25 @@
+# ports collection makefile for: perl interface to TokyoTyrant
+# Date created: 17 February 2010
+# Whom: Hiroyuki Hanai <hanai@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tokyotyrant
+PORTVERSION= 1.16
+CATEGORIES= databases perl5
+MASTER_SITES= http://1978th.net/tokyotyrant/perlpkg/
+DISTNAME= ${PORTNAME}-perl-${PORTVERSION}
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl5 interface to the TokyoTyrant
+
+BUILD_DEPENDS= tokyotyrant>=1.1.40:${PORTSDIR}/databases/tokyotyrant
+LIB_DEPENDS= tokyotyrant:${PORTSDIR}/databases/tokyotyrant
+
+PERL_CONFIGURE= yes
+
+MAN3= TokyoTyrant.3
+
+.include <bsd.port.mk>