aboutsummaryrefslogtreecommitdiff
path: root/databases/pear-DB_QueryTool
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /databases/pear-DB_QueryTool
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Notes
Notes: svn path=/head/; revision=463917
Diffstat (limited to 'databases/pear-DB_QueryTool')
-rw-r--r--databases/pear-DB_QueryTool/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/databases/pear-DB_QueryTool/Makefile b/databases/pear-DB_QueryTool/Makefile
index 1a73b3f7a104..f02f93bbf673 100644
--- a/databases/pear-DB_QueryTool/Makefile
+++ b/databases/pear-DB_QueryTool/Makefile
@@ -8,10 +8,10 @@ CATEGORIES= databases www pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= PEAR OO-interface for easily retrieving and modifying data in a DB
-BUILD_DEPENDS= ${PEARDIR}/DB.php:databases/pear-DB \
- ${PEARDIR}/Log/null.php:sysutils/pear-Log
-RUN_DEPENDS= ${PEARDIR}/DB.php:databases/pear-DB \
- ${PEARDIR}/Log/null.php:sysutils/pear-Log
+BUILD_DEPENDS= ${PEARDIR}/DB.php:databases/pear-DB@${PHP_FLAVOR} \
+ ${PEARDIR}/Log/null.php:sysutils/pear-Log@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/DB.php:databases/pear-DB@${PHP_FLAVOR} \
+ ${PEARDIR}/Log/null.php:sysutils/pear-Log@${PHP_FLAVOR}
USES= pear