aboutsummaryrefslogtreecommitdiff
path: root/databases/pear-MDB2
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-11-27 05:37:07 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-11-27 05:37:07 +0000
commit5cdd4c3c558f6c6478f5aa62fb1cc901728e58b2 (patch)
tree78d8027eda4286612aef74b6520ce849b2252188 /databases/pear-MDB2
parentac7c9771a55ea4ad04f19ab60d246c8641eb9ae4 (diff)
downloadports-5cdd4c3c558f6c6478f5aa62fb1cc901728e58b2.tar.gz
ports-5cdd4c3c558f6c6478f5aa62fb1cc901728e58b2.zip
Notes
Diffstat (limited to 'databases/pear-MDB2')
-rw-r--r--databases/pear-MDB2/Makefile66
-rw-r--r--databases/pear-MDB2/distinfo2
-rw-r--r--databases/pear-MDB2/pkg-descr22
3 files changed, 90 insertions, 0 deletions
diff --git a/databases/pear-MDB2/Makefile b/databases/pear-MDB2/Makefile
new file mode 100644
index 000000000000..5b51ced084cf
--- /dev/null
+++ b/databases/pear-MDB2/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: pear-MDB2
+# Date created: 26 November 2004
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= MDB2
+PORTVERSION= 2.0.0
+CATEGORIES= databases www pear
+DISTNAME= ${PORTNAME}-${PORTVERSION}beta2
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR database abstraction layer
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
+
+USE_PHP= yes
+
+FILES= MDB2/Date.php MDB2/Extended.php MDB2/Iterator.php MDB2/LOB.php \
+ MDB2/Driver/fbsql.php MDB2/Driver/ibase.php MDB2/Driver/mssql.php \
+ MDB2/Driver/mysql.php MDB2/Driver/oci8.php MDB2/Driver/pgsql.php \
+ MDB2/Driver/querysim.php MDB2/Driver/sqlite.php \
+ MDB2/Driver/Datatype/Common.php MDB2/Driver/Datatype/fbsql.php \
+ MDB2/Driver/Datatype/ibase.php MDB2/Driver/Datatype/mssql.php \
+ MDB2/Driver/Datatype/mysql.php MDB2/Driver/Datatype/oci8.php \
+ MDB2/Driver/Datatype/pgsql.php MDB2/Driver/Datatype/sqlite.php \
+ MDB2/Driver/Manager/Common.php MDB2/Driver/Manager/fbsql.php \
+ MDB2/Driver/Manager/ibase.php MDB2/Driver/Manager/mssql.php \
+ MDB2/Driver/Manager/mysql.php MDB2/Driver/Manager/oci8.php \
+ MDB2/Driver/Manager/pgsql.php MDB2/Driver/Manager/sqlite.php \
+ MDB2/Driver/Native/fbsql.php MDB2/Driver/Native/ibase.php \
+ MDB2/Driver/Native/mssql.php MDB2/Driver/Native/mysql.php \
+ MDB2/Driver/Native/oci8.php MDB2/Driver/Native/pgsql.php \
+ MDB2/Driver/Native/sqlite.php MDB2/Driver/Reverse/Common.php \
+ MDB2/Driver/Reverse/fbsql.php MDB2/Driver/Reverse/ibase.php \
+ MDB2/Driver/Reverse/mssql.php MDB2/Driver/Reverse/mysql.php \
+ MDB2/Driver/Reverse/oci8.php MDB2/Driver/Reverse/pgsql.php \
+ MDB2/Driver/Reverse/sqlite.php MDB2/Tools/Manager.php \
+ MDB2/Tools/Parser.php MDB2/Tools/reverse_engineer_xml_schema.php \
+ MDB2/Wrapper/peardb.php MDB2.php
+DOCS= CONTRIBUTORS datatypes.html Driver_Datatype_skeleton.php \
+ Driver_Manager_skeleton.php Driver_Native_skeleton.php \
+ Driver_Reverse_skeleton.php Driver_skeleton.php MAINTAINERS \
+ MDB.dtd MDB.xsl querysim_readme.txt README STATUS TODO \
+ xml_schema_documentation.html examples/example.php \
+ examples/metapear_test_db.schema examples/peardb_wrapper_example.php
+TESTS= clitest.php Console_TestListener.php driver_test.schema \
+ HTML_TestListener.php lob_test.schema MDB2_api_testcase.php \
+ MDB2_bugs_testcase.php MDB2_manager_testcase.php \
+ MDB2_native_testcase.php MDB2_reverse_testcase.php \
+ MDB2_usage_testcase.php README test.php test.schema \
+ testchoose.php tests.css testUtils.php test_setup.php.dist \
+ templates/results.tpl
+
+.include <bsd.port.pre.mk>
+
+PHP_VERS= ${PHP_VERSION:S/.//g}
+
+.if defined(PHP_VERS) && ${PHP_VERS} < 420
+IGNORE= "You need PHP 4.2.0 or later to install PEAR::MDB2"
+.endif
+
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/databases/pear-MDB2/distinfo b/databases/pear-MDB2/distinfo
new file mode 100644
index 000000000000..f7761be9a0b7
--- /dev/null
+++ b/databases/pear-MDB2/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/MDB2-2.0.0beta2.tgz) = 202829a526d27207bc46823b3b5b8553
+SIZE (PEAR/MDB2-2.0.0beta2.tgz) = 176377
diff --git a/databases/pear-MDB2/pkg-descr b/databases/pear-MDB2/pkg-descr
new file mode 100644
index 000000000000..5e532479e7b5
--- /dev/null
+++ b/databases/pear-MDB2/pkg-descr
@@ -0,0 +1,22 @@
+PEAR MDB2 is a merge of the PEAR DB and Metabase php database abstraction
+layers.
+
+Note that the API will be adapted to better fit with the new php5 only PDO
+before the first stable release.
+
+It provides a common API for all support RDBMS. The main difference to most
+other DB abstraction packages is that MDB2 goes much further to ensure
+portability.
+
+Currently supported RDBMS:
+MySQL
+PostGreSQL
+Oracle
+Frontbase
+Querysim
+Interbase/Firebird
+MSSQL
+SQLite
+Other soon to follow.
+
+WWW: http://pear.php.net/package/MDB2/