aboutsummaryrefslogtreecommitdiff
path: root/databases/pgbouncer/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2007-07-22 19:02:40 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2007-07-22 19:02:40 +0000
commit784419acccd42fdeeb8e92b44a3af17b92a327fc (patch)
tree93ac3695bd1c10b9cdad30bd77eb7f181ba25258 /databases/pgbouncer/Makefile
parent59b7cdd25217444f8e7fdecb80655a4004ebcbf0 (diff)
Add pgbouncer 1.0.8, lightweight connection pooler for PostgreSQL.
Notes
Notes: svn path=/head/; revision=196066
Diffstat (limited to 'databases/pgbouncer/Makefile')
-rw-r--r--databases/pgbouncer/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/databases/pgbouncer/Makefile b/databases/pgbouncer/Makefile
new file mode 100644
index 000000000000..8cbb4db94ec3
--- /dev/null
+++ b/databases/pgbouncer/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: pgbouncer
+# Date created: 19 July 2007
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pgbouncer
+PORTVERSION= 1.0.8
+CATEGORIES= databases
+MASTER_SITES= http://pgfoundry.org/frs/download.php/1399/
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Lightweight connection pooler for PostgreSQL
+
+LIB_DEPENDS= event:${PORTSDIR}/devel/libevent
+
+USE_RC_SUBR= pgbouncer.sh
+SUB_FILES= pkg-message
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+CONFIGURE_ARGS= --with-libevent=${LOCALBASE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pgbouncer ${PREFIX}/bin/
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/etc/pgbouncer.ini ${EXAMPLESDIR}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>