aboutsummaryrefslogtreecommitdiff
path: root/databases/pgbouncer
diff options
context:
space:
mode:
authorJason Unovitch <junovitch@FreeBSD.org>2015-09-09 14:20:03 +0000
committerJason Unovitch <junovitch@FreeBSD.org>2015-09-09 14:20:03 +0000
commitced42082201236ec428dab3abb72a8007bf40a82 (patch)
tree9cdee74a2cecd81ccf65b2092963bd9d0a614247 /databases/pgbouncer
parent6e927845700e59780fa325881857a4cb0feb5a16 (diff)
downloadports-ced42082201236ec428dab3abb72a8007bf40a82.tar.gz
ports-ced42082201236ec428dab3abb72a8007bf40a82.zip
Notes
Diffstat (limited to 'databases/pgbouncer')
-rw-r--r--databases/pgbouncer/Makefile5
-rw-r--r--databases/pgbouncer/distinfo4
-rw-r--r--databases/pgbouncer/files/patch-keepalive46
3 files changed, 5 insertions, 50 deletions
diff --git a/databases/pgbouncer/Makefile b/databases/pgbouncer/Makefile
index 402c41ee08e0..17c83c481fb5 100644
--- a/databases/pgbouncer/Makefile
+++ b/databases/pgbouncer/Makefile
@@ -2,9 +2,10 @@
# $FreeBSD$
PORTNAME= pgbouncer
-PORTVERSION= 1.5.5
+PORTVERSION= 1.6.1
CATEGORIES= databases
-MASTER_SITES= https://pgbouncer.github.io/downloads/
+MASTER_SITES= https://pgbouncer.github.io/downloads/files/${PORTVERSION}/ \
+ http://pgbouncer.github.io/downloads/files/${PORTVERSION}/
MAINTAINER= m.tsatsenko@gmail.com
COMMENT= Lightweight connection pooler for PostgreSQL
diff --git a/databases/pgbouncer/distinfo b/databases/pgbouncer/distinfo
index 687f764f6d58..cafb4482960d 100644
--- a/databases/pgbouncer/distinfo
+++ b/databases/pgbouncer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pgbouncer-1.5.5.tar.gz) = d65a192d1e2e69bf445d536f10211857959fc38e0247d1974e8008253080e234
-SIZE (pgbouncer-1.5.5.tar.gz) = 336145
+SHA256 (pgbouncer-1.6.1.tar.gz) = 40ff5cd84399b4da3ba864ad654fe155a0ed085261e68f3e31b1117812b17056
+SIZE (pgbouncer-1.6.1.tar.gz) = 431076
diff --git a/databases/pgbouncer/files/patch-keepalive b/databases/pgbouncer/files/patch-keepalive
deleted file mode 100644
index 5da439c89796..000000000000
--- a/databases/pgbouncer/files/patch-keepalive
+++ /dev/null
@@ -1,46 +0,0 @@
---- src/util.c.orig 2011-12-07 15:04:13.000000000 +0400
-+++ src/util.c 2011-12-07 15:04:07.000000000 +0400
-@@ -126,7 +126,7 @@
- res = setsockopt(sock, SOL_SOCKET, SO_KEEPALIVE, &val, sizeof(val));
- if (res < 0)
- goto fail;
--#ifdef __linux__
-+#ifdef TCP_KEEPCNT
- /* set count of keepalive packets */
- if (cf_tcp_keepcnt > 0) {
- val = cf_tcp_keepcnt;
-@@ -134,6 +134,8 @@
- if (res < 0)
- goto fail;
- }
-+#endif
-+#ifdef TCP_KEEPIDLE
- /* how long the connection can stay idle before sending keepalive pkts */
- if (cf_tcp_keepidle) {
- val = cf_tcp_keepidle;
-@@ -141,6 +143,8 @@
- if (res < 0)
- goto fail;
- }
-+#endif
-+#ifdef TCP_KEEPINTVL
- /* time between packets */
- if (cf_tcp_keepintvl) {
- val = cf_tcp_keepintvl;
-@@ -148,7 +152,7 @@
- if (res < 0)
- goto fail;
- }
--#else
-+#endif
- #ifdef TCP_KEEPALIVE
- if (cf_tcp_keepidle) {
- val = cf_tcp_keepidle;
-@@ -157,7 +161,6 @@
- goto fail;
- }
- #endif
--#endif
- }
-
- /* set in-kernel socket buffer size */