aboutsummaryrefslogtreecommitdiff
path: root/databases/pgfouine
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-01 01:08:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-01 01:08:05 +0000
commite3d80b4a1aba4653b82f8044e5caa87637cc4e7c (patch)
tree67fb361e6e976bf208587963b69791a4361c1a45 /databases/pgfouine
parent5e72fdf201a215b722894c8ac33c9fa6208c0893 (diff)
downloadports-e3d80b4a1aba4653b82f8044e5caa87637cc4e7c.tar.gz
ports-e3d80b4a1aba4653b82f8044e5caa87637cc4e7c.zip
Notes
Diffstat (limited to 'databases/pgfouine')
-rw-r--r--databases/pgfouine/Makefile38
-rw-r--r--databases/pgfouine/distinfo3
-rw-r--r--databases/pgfouine/files/patch-pgfouine.php11
-rw-r--r--databases/pgfouine/files/patch-pgfouine_vacuum.php11
-rw-r--r--databases/pgfouine/pkg-descr6
-rw-r--r--databases/pgfouine/pkg-plist221
6 files changed, 290 insertions, 0 deletions
diff --git a/databases/pgfouine/Makefile b/databases/pgfouine/Makefile
new file mode 100644
index 000000000000..efaedaea617f
--- /dev/null
+++ b/databases/pgfouine/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: pgfouine
+# Date created: 01 May 2008
+# Whom: Pierre-Emmanuel Andre <pea@raveland.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pgfouine
+PORTVERSION= 1.0
+CATEGORIES= databases
+MASTER_SITES= http://pgfoundry.org/frs/download.php/1334/
+
+MAINTAINER= pea@raveland.org
+COMMENT= PostgreSQL log analyzer
+
+NO_BUILD = Yes
+USE_PHP= gd
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's,/usr/bin/php,${LOCALBASE}/bin/php,g;' \
+ -e 's,!!PREFIX!!,${PREFIX},g' \
+ ${WRKSRC}/pgfouine.php ${WRKSRC}/pgfouine_vacuum.php
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/pgfouine.php ${PREFIX}/bin/pgfouine
+ ${INSTALL_SCRIPT} ${WRKSRC}/pgfouine_vacuum.php ${PREFIX}/bin/pgfouine_vacuum
+ ${MKDIR} ${DATADIR}/include
+ ${INSTALL_DATA} ${WRKSRC}/version.php ${DATADIR}
+ @cd ${WRKSRC}/include && ${COPYTREE_SHARE} \* ${DATADIR}/include/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/AUTHORS ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/THANKS ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/rpm-specific/sources/pgfouine-tutorial.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/databases/pgfouine/distinfo b/databases/pgfouine/distinfo
new file mode 100644
index 000000000000..b21c1c34bc13
--- /dev/null
+++ b/databases/pgfouine/distinfo
@@ -0,0 +1,3 @@
+MD5 (pgfouine-1.0.tar.gz) = a6c10e69582f7beef74e8de9313675e9
+SHA256 (pgfouine-1.0.tar.gz) = 48a656c8604e4e743a39782e18440d90beb277db725ef4813ab5cdc06e6f67a4
+SIZE (pgfouine-1.0.tar.gz) = 469475
diff --git a/databases/pgfouine/files/patch-pgfouine.php b/databases/pgfouine/files/patch-pgfouine.php
new file mode 100644
index 000000000000..ace21afd9ded
--- /dev/null
+++ b/databases/pgfouine/files/patch-pgfouine.php
@@ -0,0 +1,11 @@
+--- pgfouine.php.orig 2008-05-06 13:53:52.000000000 +0200
++++ pgfouine.php 2008-05-06 13:54:32.000000000 +0200
+@@ -32,6 +32,8 @@ if(strpos(phpversion(), '4.4') === 0) {
+ error_reporting(E_ALL);
+ }
+
++ini_set('include_path', '!!PREFIX!!/share/pgfouine');
++
+ include('version.php');
+ require_once('include/lib/common.lib.php');
+ require_once('include/base.lib.php');
diff --git a/databases/pgfouine/files/patch-pgfouine_vacuum.php b/databases/pgfouine/files/patch-pgfouine_vacuum.php
new file mode 100644
index 000000000000..098d059e4498
--- /dev/null
+++ b/databases/pgfouine/files/patch-pgfouine_vacuum.php
@@ -0,0 +1,11 @@
+--- pgfouine_vacuum.php.orig 2008-05-06 13:54:43.000000000 +0200
++++ pgfouine_vacuum.php 2008-05-06 13:55:02.000000000 +0200
+@@ -30,6 +30,8 @@ if(strpos(phpversion(), '4.4') === 0) {
+ error_reporting(E_ALL);
+ }
+
++ini_set('include_path', '!!PREFIX!!/share/pgfouine');
++
+ include('version.php');
+ require_once('include/lib/common.lib.php');
+ require_once('include/base.lib.php');
diff --git a/databases/pgfouine/pkg-descr b/databases/pgfouine/pkg-descr
new file mode 100644
index 000000000000..1b7807d68860
--- /dev/null
+++ b/databases/pgfouine/pkg-descr
@@ -0,0 +1,6 @@
+pgFouine is a PostgreSQL log analyzer used to generate detailed reports
+from a PostgreSQL log file. pgFouine can help you to determine which
+queries you should optimize to speed up your PostgreSQL based
+application.
+
+WWW: http://pgfouine.projects.postgresql.org/
diff --git a/databases/pgfouine/pkg-plist b/databases/pgfouine/pkg-plist
new file mode 100644
index 000000000000..00b59aab53e4
--- /dev/null
+++ b/databases/pgfouine/pkg-plist
@@ -0,0 +1,221 @@
+bin/pgfouine
+bin/pgfouine_vacuum
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/THANKS
+%%PORTDOCS%%%%DOCSDIR%%/pgfouine-tutorial.txt
+%%DATADIR%%/include/Accumulator.class.php
+%%DATADIR%%/include/DurationLogObject.class.php
+%%DATADIR%%/include/ErrorLogObject.class.php
+%%DATADIR%%/include/GenericLogReader.class.php
+%%DATADIR%%/include/LogBlock.class.php
+%%DATADIR%%/include/LogObject.class.php
+%%DATADIR%%/include/LogStream.class.php
+%%DATADIR%%/include/NormalizedError.class.php
+%%DATADIR%%/include/NormalizedQuery.class.php
+%%DATADIR%%/include/Parser.class.php
+%%DATADIR%%/include/PreparedStatementLogObject.class.php
+%%DATADIR%%/include/QueryLogObject.class.php
+%%DATADIR%%/include/SlowestQueryList.class.php
+%%DATADIR%%/include/UselessLogObject.class.php
+%%DATADIR%%/include/base.lib.php
+%%DATADIR%%/include/lib/Profiler.class.php
+%%DATADIR%%/include/lib/common.lib.php
+%%DATADIR%%/include/listeners/error/ErrorListener.class.php
+%%DATADIR%%/include/listeners/error/GlobalErrorCountersListener.class.php
+%%DATADIR%%/include/listeners/error/NormalizedErrorsListener.class.php
+%%DATADIR%%/include/listeners/error/PrintErrorListener.class.php
+%%DATADIR%%/include/listeners/listeners.lib.php
+%%DATADIR%%/include/listeners/query/GlobalCountersListener.class.php
+%%DATADIR%%/include/listeners/query/HourlyCountersListener.class.php
+%%DATADIR%%/include/listeners/query/NormalizedQueriesListener.class.php
+%%DATADIR%%/include/listeners/query/PrintQueryListener.class.php
+%%DATADIR%%/include/listeners/query/QueriesHistoryListener.class.php
+%%DATADIR%%/include/listeners/query/QueryListener.class.php
+%%DATADIR%%/include/listeners/query/SlowestQueriesListener.class.php
+%%DATADIR%%/include/listeners/query/TsungSessionsListener.class.php
+%%DATADIR%%/include/postgresql/PostgreSQLAccumulator.class.php
+%%DATADIR%%/include/postgresql/PostgreSQLRegexps.lib.php
+%%DATADIR%%/include/postgresql/lines/PostgreSQLContextLine.class.php
+%%DATADIR%%/include/postgresql/lines/PostgreSQLContinuationLine.class.php
+%%DATADIR%%/include/postgresql/lines/PostgreSQLDetailLine.class.php
+%%DATADIR%%/include/postgresql/lines/PostgreSQLDurationLine.class.php
+%%DATADIR%%/include/postgresql/lines/PostgreSQLErrorLine.class.php
+%%DATADIR%%/include/postgresql/lines/PostgreSQLHintLine.class.php
+%%DATADIR%%/include/postgresql/lines/PostgreSQLLogLine.class.php
+%%DATADIR%%/include/postgresql/lines/PostgreSQLNoticeLine.class.php
+%%DATADIR%%/include/postgresql/lines/PostgreSQLPreparedStatementExecuteLine.class.php
+%%DATADIR%%/include/postgresql/lines/PostgreSQLPreparedStatementExecuteWithDurationLine.class.php
+%%DATADIR%%/include/postgresql/lines/PostgreSQLPreparedStatementUselessLine.class.php
+%%DATADIR%%/include/postgresql/lines/PostgreSQLQueryStartLine.class.php
+%%DATADIR%%/include/postgresql/lines/PostgreSQLQueryStartWithDurationLine.class.php
+%%DATADIR%%/include/postgresql/lines/PostgreSQLStatementLine.class.php
+%%DATADIR%%/include/postgresql/lines/PostgreSQLStatusLine.class.php
+%%DATADIR%%/include/postgresql/parsers/PostgreSQLParser.class.php
+%%DATADIR%%/include/postgresql/parsers/StderrPostgreSQLParser.class.php
+%%DATADIR%%/include/postgresql/parsers/SyslogPostgreSQLParser.class.php
+%%DATADIR%%/include/postgresql/postgresql.lib.php
+%%DATADIR%%/include/postgresql/vacuum/PostgreSQLVacuumAccumulator.class.php
+%%DATADIR%%/include/postgresql/vacuum/PostgreSQLVacuumRegexps.lib.php
+%%DATADIR%%/include/postgresql/vacuum/VacuumLogStream.class.php
+%%DATADIR%%/include/postgresql/vacuum/lines/PostgreSQLAnalyzingTableLine.class.php
+%%DATADIR%%/include/postgresql/vacuum/lines/PostgreSQLFSMInformationDetailLine.class.php
+%%DATADIR%%/include/postgresql/vacuum/lines/PostgreSQLFSMInformationLine.class.php
+%%DATADIR%%/include/postgresql/vacuum/lines/PostgreSQLIndexCleanupDetailLine.class.php
+%%DATADIR%%/include/postgresql/vacuum/lines/PostgreSQLIndexCleanupInformationLine.class.php
+%%DATADIR%%/include/postgresql/vacuum/lines/PostgreSQLVacuumContinuationLine.class.php
+%%DATADIR%%/include/postgresql/vacuum/lines/PostgreSQLVacuumCpuDetailLine.class.php
+%%DATADIR%%/include/postgresql/vacuum/lines/PostgreSQLVacuumDetailLine.class.php
+%%DATADIR%%/include/postgresql/vacuum/lines/PostgreSQLVacuumEndLine.class.php
+%%DATADIR%%/include/postgresql/vacuum/lines/PostgreSQLVacuumLogLine.class.php
+%%DATADIR%%/include/postgresql/vacuum/lines/PostgreSQLVacuumOperationInformationLine.class.php
+%%DATADIR%%/include/postgresql/vacuum/lines/PostgreSQLVacuumRemovableInformationLine.class.php
+%%DATADIR%%/include/postgresql/vacuum/lines/PostgreSQLVacuumingDatabaseLine.class.php
+%%DATADIR%%/include/postgresql/vacuum/lines/PostgreSQLVacuumingTableLine.class.php
+%%DATADIR%%/include/postgresql/vacuum/listeners/FSMInformationListener.class.php
+%%DATADIR%%/include/postgresql/vacuum/listeners/VacuumOverallListener.class.php
+%%DATADIR%%/include/postgresql/vacuum/listeners/VacuumedTablesListener.class.php
+%%DATADIR%%/include/postgresql/vacuum/objects/AnalyzeTableLogObject.class.php
+%%DATADIR%%/include/postgresql/vacuum/objects/FSMInformationLogObject.class.php
+%%DATADIR%%/include/postgresql/vacuum/objects/VacuumIndexInformation.class.php
+%%DATADIR%%/include/postgresql/vacuum/objects/VacuumLogObject.class.php
+%%DATADIR%%/include/postgresql/vacuum/objects/VacuumTableLogObject.class.php
+%%DATADIR%%/include/postgresql/vacuum/parsers/PostgreSQLVacuumParser.class.php
+%%DATADIR%%/include/postgresql/vacuum/reporting/reports/FSMInformationReport.class.php
+%%DATADIR%%/include/postgresql/vacuum/reporting/reports/VacuumOverallReport.class.php
+%%DATADIR%%/include/postgresql/vacuum/reporting/reports/VacuumedTablesDetailsReport.class.php
+%%DATADIR%%/include/postgresql/vacuum/reporting/reports/VacuumedTablesReport.class.php
+%%DATADIR%%/include/postgresql/vacuum/vacuum.lib.php
+%%DATADIR%%/include/reporting/HtmlReportAggregator.class.php
+%%DATADIR%%/include/reporting/HtmlWithGraphsReportAggregator.class.php
+%%DATADIR%%/include/reporting/ReportAggregator.class.php
+%%DATADIR%%/include/reporting/TextReportAggregator.class.php
+%%DATADIR%%/include/reporting/artichow/AntiSpam.class.php
+%%DATADIR%%/include/reporting/artichow/Artichow.cfg.php
+%%DATADIR%%/include/reporting/artichow/BarPlot.class.php
+%%DATADIR%%/include/reporting/artichow/ChangeLog
+%%DATADIR%%/include/reporting/artichow/Graph.class.php
+%%DATADIR%%/include/reporting/artichow/Image.class.php
+%%DATADIR%%/include/reporting/artichow/LinePlot.class.php
+%%DATADIR%%/include/reporting/artichow/MathPlot.class.php
+%%DATADIR%%/include/reporting/artichow/Pattern.class.php
+%%DATADIR%%/include/reporting/artichow/Pie.class.php
+%%DATADIR%%/include/reporting/artichow/README
+%%DATADIR%%/include/reporting/artichow/ScatterPlot.class.php
+%%DATADIR%%/include/reporting/artichow/font/COPYRIGHT.TXT
+%%DATADIR%%/include/reporting/artichow/font/Vera.ttf
+%%DATADIR%%/include/reporting/artichow/patterns/BarDepth.php
+%%DATADIR%%/include/reporting/artichow/patterns/LightLine.php
+%%DATADIR%%/include/reporting/artichow/php4/AntiSpam.class.php
+%%DATADIR%%/include/reporting/artichow/php4/Artichow.class.php
+%%DATADIR%%/include/reporting/artichow/php4/BarPlot.class.php
+%%DATADIR%%/include/reporting/artichow/php4/Component.class.php
+%%DATADIR%%/include/reporting/artichow/php4/Graph.class.php
+%%DATADIR%%/include/reporting/artichow/php4/Image.class.php
+%%DATADIR%%/include/reporting/artichow/php4/LinePlot.class.php
+%%DATADIR%%/include/reporting/artichow/php4/MathPlot.class.php
+%%DATADIR%%/include/reporting/artichow/php4/Pattern.class.php
+%%DATADIR%%/include/reporting/artichow/php4/Pie.class.php
+%%DATADIR%%/include/reporting/artichow/php4/Plot.class.php
+%%DATADIR%%/include/reporting/artichow/php4/ScatterPlot.class.php
+%%DATADIR%%/include/reporting/artichow/php4/common.php
+%%DATADIR%%/include/reporting/artichow/php4/inc/Axis.class.php
+%%DATADIR%%/include/reporting/artichow/php4/inc/Border.class.php
+%%DATADIR%%/include/reporting/artichow/php4/inc/Color.class.php
+%%DATADIR%%/include/reporting/artichow/php4/inc/Drawer.class.php
+%%DATADIR%%/include/reporting/artichow/php4/inc/Font.class.php
+%%DATADIR%%/include/reporting/artichow/php4/inc/Gradient.class.php
+%%DATADIR%%/include/reporting/artichow/php4/inc/Grid.class.php
+%%DATADIR%%/include/reporting/artichow/php4/inc/Label.class.php
+%%DATADIR%%/include/reporting/artichow/php4/inc/Legend.class.php
+%%DATADIR%%/include/reporting/artichow/php4/inc/Mark.class.php
+%%DATADIR%%/include/reporting/artichow/php4/inc/Math.class.php
+%%DATADIR%%/include/reporting/artichow/php4/inc/Shadow.class.php
+%%DATADIR%%/include/reporting/artichow/php4/inc/Text.class.php
+%%DATADIR%%/include/reporting/artichow/php4/inc/Tick.class.php
+%%DATADIR%%/include/reporting/artichow/php4/inc/Tools.class.php
+%%DATADIR%%/include/reporting/artichow/php5/AntiSpam.class.php
+%%DATADIR%%/include/reporting/artichow/php5/Artichow.class.php
+%%DATADIR%%/include/reporting/artichow/php5/BarPlot.class.php
+%%DATADIR%%/include/reporting/artichow/php5/Component.class.php
+%%DATADIR%%/include/reporting/artichow/php5/Graph.class.php
+%%DATADIR%%/include/reporting/artichow/php5/Image.class.php
+%%DATADIR%%/include/reporting/artichow/php5/LinePlot.class.php
+%%DATADIR%%/include/reporting/artichow/php5/MathPlot.class.php
+%%DATADIR%%/include/reporting/artichow/php5/Pattern.class.php
+%%DATADIR%%/include/reporting/artichow/php5/Pie.class.php
+%%DATADIR%%/include/reporting/artichow/php5/Plot.class.php
+%%DATADIR%%/include/reporting/artichow/php5/ScatterPlot.class.php
+%%DATADIR%%/include/reporting/artichow/php5/common.php
+%%DATADIR%%/include/reporting/artichow/php5/inc/Axis.class.php
+%%DATADIR%%/include/reporting/artichow/php5/inc/Border.class.php
+%%DATADIR%%/include/reporting/artichow/php5/inc/Color.class.php
+%%DATADIR%%/include/reporting/artichow/php5/inc/Drawer.class.php
+%%DATADIR%%/include/reporting/artichow/php5/inc/Font.class.php
+%%DATADIR%%/include/reporting/artichow/php5/inc/Gradient.class.php
+%%DATADIR%%/include/reporting/artichow/php5/inc/Grid.class.php
+%%DATADIR%%/include/reporting/artichow/php5/inc/Label.class.php
+%%DATADIR%%/include/reporting/artichow/php5/inc/Legend.class.php
+%%DATADIR%%/include/reporting/artichow/php5/inc/Mark.class.php
+%%DATADIR%%/include/reporting/artichow/php5/inc/Math.class.php
+%%DATADIR%%/include/reporting/artichow/php5/inc/Shadow.class.php
+%%DATADIR%%/include/reporting/artichow/php5/inc/Text.class.php
+%%DATADIR%%/include/reporting/artichow/php5/inc/Tick.class.php
+%%DATADIR%%/include/reporting/artichow/php5/inc/Tools.class.php
+%%DATADIR%%/include/reporting/geshi/docs/BUGS
+%%DATADIR%%/include/reporting/geshi/docs/CHANGES
+%%DATADIR%%/include/reporting/geshi/docs/COPYING
+%%DATADIR%%/include/reporting/geshi/docs/README
+%%DATADIR%%/include/reporting/geshi/docs/THANKS
+%%DATADIR%%/include/reporting/geshi/geshi.php
+%%DATADIR%%/include/reporting/geshi/geshi/sql.php
+%%DATADIR%%/include/reporting/reports.lib.php
+%%DATADIR%%/include/reporting/reports/HourlyStatsReport.class.php
+%%DATADIR%%/include/reporting/reports/NormalizedErrorsMostFrequentReport.class.php
+%%DATADIR%%/include/reporting/reports/NormalizedErrorsReport.class.php
+%%DATADIR%%/include/reporting/reports/NormalizedQueriesMostFrequentReport.class.php
+%%DATADIR%%/include/reporting/reports/NormalizedQueriesMostTimeReport.class.php
+%%DATADIR%%/include/reporting/reports/NormalizedQueriesSlowestAverageReport.class.php
+%%DATADIR%%/include/reporting/reports/NormalizedReport.class.php
+%%DATADIR%%/include/reporting/reports/OverallStatsReport.class.php
+%%DATADIR%%/include/reporting/reports/QueriesByTypeReport.class.php
+%%DATADIR%%/include/reporting/reports/QueriesHistoryPerPidReport.class.php
+%%DATADIR%%/include/reporting/reports/QueriesHistoryReport.class.php
+%%DATADIR%%/include/reporting/reports/Report.class.php
+%%DATADIR%%/include/reporting/reports/SlowestQueriesReport.class.php
+%%DATADIR%%/include/reporting/reports/TsungSessionsReport.class.php
+%%DATADIR%%/include/reporting/web/css/common.css
+%%DATADIR%%/include/reporting/web/js/sorttable.js
+%%DATADIR%%/version.php
+@dirrm %%DATADIR%%/include/reporting/web/js
+@dirrm %%DATADIR%%/include/reporting/web/css
+@dirrm %%DATADIR%%/include/reporting/web
+@dirrm %%DATADIR%%/include/reporting/reports
+@dirrm %%DATADIR%%/include/reporting/geshi/geshi
+@dirrm %%DATADIR%%/include/reporting/geshi/docs
+@dirrm %%DATADIR%%/include/reporting/geshi
+@dirrm %%DATADIR%%/include/reporting/artichow/php5/inc
+@dirrm %%DATADIR%%/include/reporting/artichow/php5
+@dirrm %%DATADIR%%/include/reporting/artichow/php4/inc
+@dirrm %%DATADIR%%/include/reporting/artichow/php4
+@dirrm %%DATADIR%%/include/reporting/artichow/patterns
+@dirrm %%DATADIR%%/include/reporting/artichow/font
+@dirrm %%DATADIR%%/include/reporting/artichow
+@dirrm %%DATADIR%%/include/reporting
+@dirrm %%DATADIR%%/include/postgresql/vacuum/reporting/reports
+@dirrm %%DATADIR%%/include/postgresql/vacuum/reporting
+@dirrm %%DATADIR%%/include/postgresql/vacuum/parsers
+@dirrm %%DATADIR%%/include/postgresql/vacuum/objects
+@dirrm %%DATADIR%%/include/postgresql/vacuum/listeners
+@dirrm %%DATADIR%%/include/postgresql/vacuum/lines
+@dirrm %%DATADIR%%/include/postgresql/vacuum
+@dirrm %%DATADIR%%/include/postgresql/parsers
+@dirrm %%DATADIR%%/include/postgresql/lines
+@dirrm %%DATADIR%%/include/postgresql
+@dirrm %%DATADIR%%/include/listeners/query
+@dirrm %%DATADIR%%/include/listeners/error
+@dirrm %%DATADIR%%/include/listeners
+@dirrm %%DATADIR%%/include/lib
+@dirrm %%DATADIR%%/include
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%