aboutsummaryrefslogtreecommitdiff
path: root/databases/pgpool-II-41
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2020-03-29 21:48:12 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2020-03-29 21:48:12 +0000
commit63a01ab6dcbadf0afb8a0a5c1fcd5981e05c4447 (patch)
tree288e10d869d3339a36a963c64974a430bbc0c97b /databases/pgpool-II-41
parent1376889b59e1ab17cf6d76fc0c74d7bd888a83ec (diff)
downloadports-63a01ab6dcbadf0afb8a0a5c1fcd5981e05c4447.tar.gz
ports-63a01ab6dcbadf0afb8a0a5c1fcd5981e05c4447.zip
Notes
Diffstat (limited to 'databases/pgpool-II-41')
-rw-r--r--databases/pgpool-II-41/Makefile52
-rw-r--r--databases/pgpool-II-41/distinfo3
-rw-r--r--databases/pgpool-II-41/files/pgpool.in50
-rw-r--r--databases/pgpool-II-41/pkg-descr8
-rw-r--r--databases/pgpool-II-41/pkg-message15
-rw-r--r--databases/pgpool-II-41/pkg-plist41
6 files changed, 169 insertions, 0 deletions
diff --git a/databases/pgpool-II-41/Makefile b/databases/pgpool-II-41/Makefile
new file mode 100644
index 000000000000..08ab23888e53
--- /dev/null
+++ b/databases/pgpool-II-41/Makefile
@@ -0,0 +1,52 @@
+# $FreeBSD$
+
+PORTNAME= pgpool-II
+PORTVERSION= 4.1.1
+CATEGORIES= databases
+MASTER_SITES= http://www.pgpool.net/mediawiki/images/
+PKGNAMESUFFIX= 41
+
+MAINTAINER= tz@FreeBSD.org
+COMMENT= Connection pool server for PostgreSQL
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+PORTSCOUT= limit:^4.1.[0-9]*
+
+USES= gmake libtool pgsql:9.6+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+USE_RC_SUBR= pgpool
+CONFLICTS= pgpool-II-[0-9]*
+
+PORTDOCS= *
+
+PAM_DESC= Build with PAM support
+SSL_DESC= Build with OpenSSL support
+MEMCACHED_DESC = Use memcached for in memory query cache
+
+OPTIONS_DEFINE= DOCS SSL PAM MEMCACHED
+OPTIONS_DEFAULT= SSL
+
+MEMCACHED_CONFIGURE_ON= --with-memcached=${LOCALBASE}/include
+MEMCACHED_LIB_DEPENDS= libmemcached.so:databases/libmemcached
+
+PAM_CONFIGURE_ON= --with-pam
+
+SSL_CONFIGURE_WITH= openssl
+SSL_USES= ssl
+
+post-install:
+ @${MKDIR} ${STAGEDIR}/var/run/pgpool
+ ${INSTALL_LIB} ${WRKSRC}/src/libs/pcp/.libs/libpcp.so.1.0.0 ${STAGEDIR}${PREFIX}/lib
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} doc ${STAGEDIR}${DOCSDIR} "-not -name Makefile.\*"
+.for f in AUTHORS ChangeLog NEWS TODO
+ ${INSTALL_DATA} ${WRKSRC}/$f ${STAGEDIR}${DOCSDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/databases/pgpool-II-41/distinfo b/databases/pgpool-II-41/distinfo
new file mode 100644
index 000000000000..7d854c7b1ec8
--- /dev/null
+++ b/databases/pgpool-II-41/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1583510780
+SHA256 (pgpool-II-4.1.1.tar.gz) = b6e334984aeed36e1a882266e65963dd0f5145d19bc0b30019c0b566dce33b61
+SIZE (pgpool-II-4.1.1.tar.gz) = 4238410
diff --git a/databases/pgpool-II-41/files/pgpool.in b/databases/pgpool-II-41/files/pgpool.in
new file mode 100644
index 000000000000..671cd6a80467
--- /dev/null
+++ b/databases/pgpool-II-41/files/pgpool.in
@@ -0,0 +1,50 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: pgpool
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# pgpool_enable (bool): Set to NO by default.
+# Set it to YES to enable pgpool.
+# pgpool_conf (file): Set location of your config.
+# Default is "%%PREFIX%%/etc/pgpool.conf"
+# pgpool_hba (file): Set location of your pool hba file.
+# Default is "%%PREFIX%%/etc/pool_hba.conf"
+# pgpool_pcp (file): Set location of your pcp conf file.
+# Default is "%%PREFIX%%/etc/pcp.conf"
+# pgpool_user (uid): User ID to run as (default nobody)
+# pgpool_stop_mode (string): Shutdown mode
+# Default is "smart"
+# Possibilities are "smart", "fast", or "immediate"
+#
+
+. /etc/rc.subr
+
+name=pgpool
+rcvar=pgpool_enable
+
+load_rc_config $name
+
+: ${pgpool_enable="NO"}
+: ${pgpool_conf="%%PREFIX%%/etc/pgpool.conf"}
+: ${pgpool_hba="%%PREFIX%%/etc/pool_hba.conf"}
+: ${pgpool_pcp="%%PREFIX%%/etc/pcp.conf"}
+: ${pgpool_user="nobody"}
+: ${pgpool_stop_mode="smart"}
+
+command="%%PREFIX%%/bin/pgpool"
+command_args="-f ${pgpool_conf} -a ${pgpool_hba} -F ${pgpool_pcp}"
+stop_cmd="${command} -m ${pgpool_stop_mode} ${command_args} stop"
+reload_cmd="${command} ${command_args} reload"
+extra_commands="reload"
+
+required_files="${pgpool_conf}"
+
+
+run_rc_command "$1"
+
diff --git a/databases/pgpool-II-41/pkg-descr b/databases/pgpool-II-41/pkg-descr
new file mode 100644
index 000000000000..474bcbe9a30e
--- /dev/null
+++ b/databases/pgpool-II-41/pkg-descr
@@ -0,0 +1,8 @@
+pgpool is a connection pool server for PostgreSQL. pgpool runs between
+PostgreSQL's clients(front ends) and servers(back ends). A PostgreSQL client can
+connect to pgpool as if it were a standard PostgreSQL server.
+
+pgpool caches the connection to PostgreSQL server to reduce the overhead to
+establish the connection to it.
+
+WWW: https://pgpool.net/
diff --git a/databases/pgpool-II-41/pkg-message b/databases/pgpool-II-41/pkg-message
new file mode 100644
index 000000000000..1df287cd433a
--- /dev/null
+++ b/databases/pgpool-II-41/pkg-message
@@ -0,0 +1,15 @@
+[
+{ type: install
+ message: <<EOM
+In order to start pgpool you need some more configuration:
+
+# sysrc -f /etc/rc.conf pgpool_enable="YES"
+# sysrc -f /etc/rc.conf pgpool_user="root"
+
+Please consider the usage of another user. The user is
+required to have read/write access to /var/run/pgpool.
+
+Using the root user is - as always - an security issue.
+EOM
+}
+]
diff --git a/databases/pgpool-II-41/pkg-plist b/databases/pgpool-II-41/pkg-plist
new file mode 100644
index 000000000000..a08ac34b2637
--- /dev/null
+++ b/databases/pgpool-II-41/pkg-plist
@@ -0,0 +1,41 @@
+bin/pcp_attach_node
+bin/pcp_detach_node
+bin/pcp_node_count
+bin/pcp_node_info
+bin/pcp_pool_status
+bin/pcp_proc_count
+bin/pcp_proc_info
+bin/pcp_promote_node
+bin/pcp_recovery_node
+bin/pcp_stop_pgpool
+bin/pcp_watchdog_info
+bin/pg_enc
+bin/pg_md5
+bin/pgpool
+bin/pgpool_setup
+bin/pgproto
+bin/watchdog_setup
+@sample etc/failover.sh.sample
+@sample etc/follow_master.sh.sample
+@sample etc/pcp.conf.sample
+@sample etc/pgpool.conf.sample
+@sample etc/pgpool.conf.sample-logical
+@sample etc/pgpool.conf.sample-master-slave
+@sample etc/pgpool.conf.sample-replication
+@sample etc/pgpool.conf.sample-stream
+@sample etc/pgpool_remote_start.sample
+@sample etc/pool_hba.conf.sample
+etc/rc.d/pgpool
+etc/recovery_1st_stage.sample
+etc/recovery_2nd_stage.sample
+include/libpcp_ext.h
+include/pcp.h
+include/pool_process_reporting.h
+include/pool_type.h
+lib/libpcp.a
+lib/libpcp.so
+lib/libpcp.so.1
+lib/libpcp.so.1.0.0
+%%DATADIR%%/insert_lock.sql
+%%DATADIR%%/pgpool.pam
+@dir /var/run/pgpool