aboutsummaryrefslogtreecommitdiff
path: root/databases/pgreplay
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2016-05-25 10:12:50 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2016-05-25 10:12:50 +0000
commit37905c446ea27048138d432c7cf733386d4e1464 (patch)
tree5ca71dc338be94363461ae5494437cc7e60ade4f /databases/pgreplay
parentb7df7b5d2e1e457b4b3a86104f03fc563c1c4756 (diff)
Notes
Diffstat (limited to 'databases/pgreplay')
-rw-r--r--databases/pgreplay/Makefile28
-rw-r--r--databases/pgreplay/distinfo3
-rw-r--r--databases/pgreplay/files/patch-Makefile.in14
-rw-r--r--databases/pgreplay/pkg-descr5
4 files changed, 50 insertions, 0 deletions
diff --git a/databases/pgreplay/Makefile b/databases/pgreplay/Makefile
new file mode 100644
index 000000000000..0c371541f6d5
--- /dev/null
+++ b/databases/pgreplay/Makefile
@@ -0,0 +1,28 @@
+# Created by: Matthew Seaman
+# $FreeBSD$
+
+PORTNAME= pgreplay
+PORTVERSION= 1.2.0
+CATEGORIES= databases
+
+MAINTAINER= matthew@FreeBSD.org
+COMMENT= Replay SQL statements from a Postgresql Log
+
+LICENSE= PostgreSQL
+
+USE_GITHUB= yes
+GH_ACCOUNT= laurenz
+GH_TAGNAME= PGREPLAY_1_2_0
+
+USES= pgsql autoreconf
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/pgreplay man/man1/pgreplay.1.gz
+
+ALL_TARGET= ${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pgreplay ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/pgreplay.1 ${STAGEDIR}${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/databases/pgreplay/distinfo b/databases/pgreplay/distinfo
new file mode 100644
index 000000000000..528afea981d8
--- /dev/null
+++ b/databases/pgreplay/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1464166606
+SHA256 (laurenz-pgreplay-1.2.0-PGREPLAY_1_2_0_GH0.tar.gz) = b2443d1ccf0c0c1da2ce9d98035e42c8f6846146b804cb3bf5a8819ca6c4123d
+SIZE (laurenz-pgreplay-1.2.0-PGREPLAY_1_2_0_GH0.tar.gz) = 118585
diff --git a/databases/pgreplay/files/patch-Makefile.in b/databases/pgreplay/files/patch-Makefile.in
new file mode 100644
index 000000000000..9e66158a85c7
--- /dev/null
+++ b/databases/pgreplay/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+--- Makefile.in.orig 2016-05-25 09:58:50 UTC
++++ Makefile.in
+@@ -1,4 +1,5 @@
+ CFLAGS = @CFLAGS@
++CPPFLAGS= @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+ CC = @CC@
+@@ -57,4 +58,4 @@ install_html: $(EXE).html
+ $(INSTALL) -D -m 0644 $< $(DESTDIR)$(htmldir)/$<
+
+ .c.o: $(HEADERS)
+- $(CC) -c $(CFLAGS) -DVERSION='"$(VERSION)"' $<
++ $(CC) -c $(CFLAGS) $(CPPFLAGS) -DVERSION='"$(VERSION)"' $<
diff --git a/databases/pgreplay/pkg-descr b/databases/pgreplay/pkg-descr
new file mode 100644
index 000000000000..5740420cde29
--- /dev/null
+++ b/databases/pgreplay/pkg-descr
@@ -0,0 +1,5 @@
+pgreplay reads a PostgreSQL log file (*not* a WAL file), extracts the
+SQL statements and executes them in the same order and with the original
+timing against a PostgreSQL database.
+
+WWW: https://github.com/laurenz/pgreplay