aboutsummaryrefslogtreecommitdiff
path: root/databases/pgsphere/Makefile
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-06-24 00:54:27 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-06-24 00:54:27 +0000
commit078a5d741919a7be140ed626640199bd6c7a79da (patch)
tree0d919a1ce11fac7fd748079c13c1a9da60557a06 /databases/pgsphere/Makefile
parentcb1ddcee2a169f766bbbfe1bc405e2467efe2565 (diff)
Workaround the following problem on aarch64 by setting LLD_UNSAFE=yes:
cc: error: invalid linker name in argument '-fuse-ld=bfd' Neither emaste nor I can figure out exactly where the offending stanza is coming in. It will take someone with more knowledge of gmake debug flags, and possibly the src build infrastructure, to figure it out. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=473169
Diffstat (limited to 'databases/pgsphere/Makefile')
-rw-r--r--databases/pgsphere/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/databases/pgsphere/Makefile b/databases/pgsphere/Makefile
index d33f109c6360..614a7e3813e4 100644
--- a/databases/pgsphere/Makefile
+++ b/databases/pgsphere/Makefile
@@ -13,12 +13,13 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT.pg_sphere
OPTIONS_DEFINE= DOCS
+USES= gmake pgsql
+LLD_UNSAFE= yes
+USE_LDCONFIG= yes
MAKE_ARGS= PG_CONFIG=${LOCALBASE}/bin/pg_config USE_PGXS=1 \
docdir=${DOCSDIR} \
install_bin=/usr/bin/install
TEST_TARGET= installcheck
-USE_LDCONFIG= yes
-USES= gmake pgsql
DATADIR= ${PREFIX}/share/postgresql
DOCSDIR?= ${PREFIX}/share/doc/postgresql