aboutsummaryrefslogtreecommitdiff
path: root/databases/php-memcache
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-03-08 20:38:07 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-03-08 20:38:07 +0000
commitd11ff9d897b6f6c25cc356c533b0e75c6f4f11af (patch)
tree4cf37ff506ecf8f2eb7a94a2920494e088f710ce /databases/php-memcache
parentf9d1189b040f3468632c434d8765eca60b085b6e (diff)
downloadports-d11ff9d897b6f6c25cc356c533b0e75c6f4f11af.tar.gz
ports-d11ff9d897b6f6c25cc356c533b0e75c6f4f11af.zip
Fix build with PHP 7.1
PR: 236234 Submitted by: Krzysztof <ports@bsdserwis.com> Obtained from: https://github.com/websupport-sk/pecl-memcache/commit/09e21a63410cbfd8827c7a876d8160a6b80b076c
Notes
Notes: svn path=/head/; revision=495071
Diffstat (limited to 'databases/php-memcache')
-rw-r--r--databases/php-memcache/Makefile1
-rw-r--r--databases/php-memcache/files/patch-php7-memcache_pool.c14
2 files changed, 14 insertions, 1 deletions
diff --git a/databases/php-memcache/Makefile b/databases/php-memcache/Makefile
index 944e2921f425..15db678b2337 100644
--- a/databases/php-memcache/Makefile
+++ b/databases/php-memcache/Makefile
@@ -22,7 +22,6 @@ USES= dos2unix php:ext
USE_PHP= session:build zlib:build
CONFIGURE_ARGS= --with-zlib-dir=/usr
-IGNORE_WITH_PHP=71
GH_ACCOUNT= websupport-sk
GH_PROJECT= pecl-${PORTNAME}
diff --git a/databases/php-memcache/files/patch-php7-memcache_pool.c b/databases/php-memcache/files/patch-php7-memcache_pool.c
new file mode 100644
index 000000000000..4b42f98eb291
--- /dev/null
+++ b/databases/php-memcache/files/patch-php7-memcache_pool.c
@@ -0,0 +1,14 @@
+Obtained from: https://github.com/websupport-sk/pecl-memcache/commit/09e21a63410cbfd8827c7a876d8160a6b80b076c
+
+--- php7/memcache_pool.c.orig 2019-03-04 21:49:48 UTC
++++ php7/memcache_pool.c
+@@ -44,6 +44,9 @@ ZEND_DECLARE_MODULE_GLOBALS(memcache)
+ MMC_POOL_INLINE void mmc_buffer_alloc(mmc_buffer_t *buffer, unsigned int size) /*
+ ensures space for an additional size bytes {{{ */
+ {
++#if PHP_VERSION_ID < 70200
++ register size_t newlen;
++#endif
+ smart_string_alloc((&(buffer->value)), size, 0);
+ }
+ /* }}} */