aboutsummaryrefslogtreecommitdiff
path: root/databases/php-sqlite3/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-10-06 02:48:31 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-10-06 02:48:31 +0000
commit0a95ed3134930e5bce059f0c8c606f7852d0af31 (patch)
tree1de458949335b21f943a74ea354593f9d2eda308 /databases/php-sqlite3/Makefile
parentd4507b50addd3e919a56abc9344b81f6f7467fff (diff)
Notes
Diffstat (limited to 'databases/php-sqlite3/Makefile')
-rw-r--r--databases/php-sqlite3/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/databases/php-sqlite3/Makefile b/databases/php-sqlite3/Makefile
new file mode 100644
index 000000000000..a89c5a719e15
--- /dev/null
+++ b/databases/php-sqlite3/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: php-sqlite3
+# Date created: 26 Sep 2006
+# Whom: Simon Cornelius P. Umacob <simoncpu@infoweapons.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sqlite3
+PORTVERSION= 0.4
+CATEGORIES= databases
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= php-sqlite3
+PKGNAMEPREFIX= php-
+EXTRACT_SUFX= .tgz
+#DISTFILES= sqlite3-0.4.tgz
+
+MAINTAINER= simoncpu@infoweapons.com
+COMMENT= A port for the PHP sqlite3 extension
+
+BUILD_DEPENDS= sqlite>=3.0:${PORTSDIR}/databases/sqlite3
+
+CONFIGURE_ARGS= --with-sqlite3=${LOCALBASE}
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHPEXT= yes
+USE_PHP_BUILD= yes
+
+.include <bsd.port.mk>