aboutsummaryrefslogtreecommitdiff
path: root/databases/php-sqlrelay
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-07-06 10:24:50 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-07-06 10:24:50 +0000
commita38514987227418282c88beb65ecea623dcc1afe (patch)
tree930fcd265b002faffbbf5b2963844328d1424154 /databases/php-sqlrelay
parente5dd3a41a37ef2d930864ce0e1c32532f3facb3c (diff)
downloadports-a38514987227418282c88beb65ecea623dcc1afe.tar.gz
ports-a38514987227418282c88beb65ecea623dcc1afe.zip
Notes
Diffstat (limited to 'databases/php-sqlrelay')
-rw-r--r--databases/php-sqlrelay/Makefile46
-rw-r--r--databases/php-sqlrelay/pkg-comment1
-rw-r--r--databases/php-sqlrelay/pkg-descr3
-rw-r--r--databases/php-sqlrelay/pkg-plist1
4 files changed, 51 insertions, 0 deletions
diff --git a/databases/php-sqlrelay/Makefile b/databases/php-sqlrelay/Makefile
new file mode 100644
index 000000000000..70fcb5e66e4b
--- /dev/null
+++ b/databases/php-sqlrelay/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: PHP module for SQL Relay
+# Date created: 2 July 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${SQLRELAY_PORTNAME}
+PORTVERSION= ${SQLRELAY_PORTVERSION}
+CATEGORIES= databases
+MASTER_SITES= # none
+PKGNAMEPREFIX= php-
+DISTFILES= # none
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ${NONEXISTENT}:${SQLRELAY_PORTDIR}:configure \
+ php-config:${PORTSDIR}/www/mod_php4
+LIB_DEPENDS= sqlrclient.0:${SQLRELAY_PORTDIR}
+RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+
+USE_PYTHON= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+BUILD_WRKSRC= ${WRKSRC}/src/api/php
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= ${SQLRELAY_CONFIGURE_ARGS} \
+ --with-php-prefix="${LOCALBASE}"
+
+.include "${.CURDIR}/../sqlrelay/Makefile.common"
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ ${LN} -fs `${SQLRELAY_WRKSRC_CMD}` ${WRKSRC}
+
+pre-install:
+ ${MKDIR} `php-config --extension-dir`
+
+post-install:
+ dir=`php-config --extension-dir | ${SED} 's,^${LOCALBASE}/,,'`; \
+ ${ECHO} "$$dir/sql_relay.so" >> ${TMPPLIST}; \
+ ${ECHO} "@unexec rmdir %D/$$dir 2>/dev/null || true" >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/databases/php-sqlrelay/pkg-comment b/databases/php-sqlrelay/pkg-comment
new file mode 100644
index 000000000000..5b8adfa348e1
--- /dev/null
+++ b/databases/php-sqlrelay/pkg-comment
@@ -0,0 +1 @@
+PHP modules to access to SQL Relay
diff --git a/databases/php-sqlrelay/pkg-descr b/databases/php-sqlrelay/pkg-descr
new file mode 100644
index 000000000000..36262f888904
--- /dev/null
+++ b/databases/php-sqlrelay/pkg-descr
@@ -0,0 +1,3 @@
+This package provides PHP modules to access to SQL Relay.
+
+WWW: http://www.firstworks.com/sqlrelay.html
diff --git a/databases/php-sqlrelay/pkg-plist b/databases/php-sqlrelay/pkg-plist
new file mode 100644
index 000000000000..9fa4e8b90900
--- /dev/null
+++ b/databases/php-sqlrelay/pkg-plist
@@ -0,0 +1 @@
+@comment automatically generated plist follows: