aboutsummaryrefslogtreecommitdiff
path: root/databases/php53-mysqli
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2012-05-16 09:46:51 +0000
committerFlorian Smeets <flo@FreeBSD.org>2012-05-16 09:46:51 +0000
commit902a0675beeba6c01a038f9594a0c532079fd2f2 (patch)
treee640f9d726eb930319bafe09a6173a5b67843921 /databases/php53-mysqli
parentc76d4dd7170ff14ee3d83458ff9f89cdbc7a5694 (diff)
Notes
Diffstat (limited to 'databases/php53-mysqli')
-rw-r--r--databases/php53-mysqli/Makefile14
-rw-r--r--databases/php53-mysqli/files/patch-php_mysqli_structs.h10
2 files changed, 24 insertions, 0 deletions
diff --git a/databases/php53-mysqli/Makefile b/databases/php53-mysqli/Makefile
new file mode 100644
index 000000000000..132a204d7b0b
--- /dev/null
+++ b/databases/php53-mysqli/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php53-mysqli
+# Date created: 12 Apr 2012
+# Whom: Florian Smeets <flo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php53
+
+PKGNAMESUFFIX= -mysqli
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php53-mysqli/files/patch-php_mysqli_structs.h b/databases/php53-mysqli/files/patch-php_mysqli_structs.h
new file mode 100644
index 000000000000..d0daeee9ee54
--- /dev/null
+++ b/databases/php53-mysqli/files/patch-php_mysqli_structs.h
@@ -0,0 +1,10 @@
+--- php_mysqli_structs.h.orig 2010-07-26 15:52:54.000000000 +0200
++++ php_mysqli_structs.h 2010-07-26 15:53:14.000000000 +0200
+@@ -54,6 +54,7 @@
+ #define WE_HAD_MBSTATE_T
+ #endif
+
++#define HAVE_ULONG 1
+ #include <my_global.h>
+
+ #if !defined(HAVE_MBRLEN) && defined(WE_HAD_MBRLEN)