aboutsummaryrefslogtreecommitdiff
path: root/databases/php55-mysqli
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2013-06-24 14:32:11 +0000
committerAlex Dupre <ale@FreeBSD.org>2013-06-24 14:32:11 +0000
commit7fe96c109332ecdb411ceef911efd11085a88346 (patch)
treefd816d2c8b34ef7db2d6bcabe7358eaa7fb2d04f /databases/php55-mysqli
parent47b48988aa7fe1c1c0f221ce9cb124af07f62a16 (diff)
downloadports-7fe96c109332ecdb411ceef911efd11085a88346.tar.gz
ports-7fe96c109332ecdb411ceef911efd11085a88346.zip
Notes
Diffstat (limited to 'databases/php55-mysqli')
-rw-r--r--databases/php55-mysqli/Makefile10
-rw-r--r--databases/php55-mysqli/files/patch-php_mysqli_structs.h10
2 files changed, 20 insertions, 0 deletions
diff --git a/databases/php55-mysqli/Makefile b/databases/php55-mysqli/Makefile
new file mode 100644
index 000000000000..0725ba0b3756
--- /dev/null
+++ b/databases/php55-mysqli/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -mysqli
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php55-mysqli/files/patch-php_mysqli_structs.h b/databases/php55-mysqli/files/patch-php_mysqli_structs.h
new file mode 100644
index 000000000000..d0daeee9ee54
--- /dev/null
+++ b/databases/php55-mysqli/files/patch-php_mysqli_structs.h
@@ -0,0 +1,10 @@
+--- php_mysqli_structs.h.orig 2010-07-26 15:52:54.000000000 +0200
++++ php_mysqli_structs.h 2010-07-26 15:53:14.000000000 +0200
+@@ -54,6 +54,7 @@
+ #define WE_HAD_MBSTATE_T
+ #endif
+
++#define HAVE_ULONG 1
+ #include <my_global.h>
+
+ #if !defined(HAVE_MBRLEN) && defined(WE_HAD_MBRLEN)