aboutsummaryrefslogtreecommitdiff
path: root/databases/phpmyadmin211
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-05-20 16:29:49 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-05-20 16:29:49 +0000
commitd8ef2d011153327a259cfbc742fd1cedf85e466e (patch)
tree438500223e75917ccb6e2f6ef624c99b4801b747 /databases/phpmyadmin211
parent0e8d24bf420689751b8dc250b796756b88b6dcef (diff)
downloadports-d8ef2d011153327a259cfbc742fd1cedf85e466e.tar.gz
ports-d8ef2d011153327a259cfbc742fd1cedf85e466e.zip
Notes
Diffstat (limited to 'databases/phpmyadmin211')
-rw-r--r--databases/phpmyadmin211/Makefile101
-rw-r--r--databases/phpmyadmin211/pkg-deinstall-suphp26
-rw-r--r--databases/phpmyadmin211/pkg-install-suphp98
-rw-r--r--databases/phpmyadmin211/pkg-message11
-rw-r--r--databases/phpmyadmin211/pkg-plist321
-rw-r--r--databases/phpmyadmin211/pkg-plist-chunk7
6 files changed, 232 insertions, 332 deletions
diff --git a/databases/phpmyadmin211/Makefile b/databases/phpmyadmin211/Makefile
index 1b3d2fc8dd10..8f5900ddf1e1 100644
--- a/databases/phpmyadmin211/Makefile
+++ b/databases/phpmyadmin211/Makefile
@@ -7,6 +7,7 @@
PORTNAME= phpMyAdmin
PORTVERSION= 2.5.6
+PORTREVISION= 1
CATEGORIES= databases www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= phpmyadmin
@@ -15,21 +16,99 @@ MAINTAINER= m.seaman@infracaninophile.co.uk
COMMENT= A set of PHP-scripts to adminster MySQL over the web
USE_BZIP2= yes
-USE_PHP= yes
NO_BUILD= yes
-MYADMDIR?= www/data/phpMyAdmin
+.if defined(WITH_SUPHP)
+
+RUN_DEPENDS+= ${LOCALBASE}/sbin/suphp:${PORTSDIR}/www/suphp
+PKGNAMESUFFIX= -suphp
+PKGINST_SKEL= ${PKGDIR}/pkg-install${PKGNAMESUFFIX}
+PKGINSTALL= ${WRKDIR}/pkg-install${PKGNAMESUFFIX}
+PKGDEINST_SKEL= ${PKGDIR}/pkg-deinstall${PKGNAMESUFFIX}
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall${PKGNAMESUFFIX}
+
+MYADMUSR?= phpmyadm
+
+SED_SCRIPT= -e 's,%%PREFIX%%,${PREFIX},g' \
+ -e 's,%%MYADMDIR%%,${MYADMDIR},g' \
+ -e 's,%%MYADMUSR%%,${MYADMUSR},g' \
+ -e 's,%%MYADMGRP%%,${MYADMGRP},g'
+
+.else
+
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+.endif
+
+MSG_SKEL= ${PKGDIR}/pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
-PLIST_SUB+= MYADMDIR=${MYADMDIR}
+# MYADMUSR is only used WITH_SUPHP
+MYADMDIR?= www/phpMyAdmin
+MYADMGRP?= ${WWWGRP}
+CFGFILE= config.inc.php
+
+PLIST= ${WRKDIR}/plist
+PLIST_SUB+= MYADMDIR=${MYADMDIR} MYADMGRP=${MYADMGRP}
+
+.SILENT:
+
+pre-everything::
+ ${ECHO_MSG} ""
+ ${ECHO_MSG} "You may use the following build options:"
+ ${ECHO_MSG} ""
+ ${ECHO_MSG} " WITH_SUPHP=yes Install appropriately for use with"
+ ${ECHO_MSG} " the www/suphp port [default: no]"
+ ${ECHO_MSG} ""
post-patch:
- @${MV} ${WRKSRC}/config.inc.php ${WRKSRC}/config.inc.php.sample
-
-do-install:
- @${MKDIR} ${PREFIX}/${MYADMDIR}
- @${FIND} ${WRKSRC} ! -path '*/CVS*' ! -path '*/.cvsignore' | \
- ${XARGS} -n1 ${SH} -c 'if ${TEST} -d $$0; \
- then ${MKDIR} ${PREFIX}/${MYADMDIR}$${0#${WRKSRC}}; \
- else ${INSTALL_DATA} $$0 ${PREFIX}/${MYADMDIR}$${0#${WRKSRC}}; fi'
+ ${MV} ${WRKSRC}/${CFGFILE} ${WRKSRC}/${CFGFILE}.sample
+ cd ${WRKSRC} ; \
+ ${FIND} . ! -type d ! -name ${CFGFILE}.sample | ${SORT} | \
+ ${SED} -e "s,^\.,%%MYADMDIR%%," >${PLIST} ; \
+ ${CAT} ${PKGDIR}/pkg-plist-chunk >>${PLIST} ; \
+ ${FIND} . -type d | ${SORT} -r | ${SED} \
+ -e "s,^\.$$,@unexec rmdir %D/%%MYADMDIR%% 2>/dev/null || true," \
+ -e "s,^\.,@dirrm %%MYADMDIR%%," >>${PLIST}
+ ${SED} -e 's,%%MYADMDIR%%,${MYADMDIR},g' \
+ -e 's,%%PREFIX%%,${PREFIX},g' \
+ -e 's,%%PKGNAME%%,${PKGNAME},g' ${MSG_SKEL} > ${PKGMESSAGE}
+.if defined(WITH_SUPHP)
+ ${SED} ${SED_SCRIPT} ${PKGINST_SKEL} > ${PKGINSTALL}
+ ${SED} ${SED_SCRIPT} ${PKGDEINST_SKEL} > ${PKGDEINSTALL}
+.endif
+
+pre-install:
+.if defined(WITH_SUPHP)
+ ${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+.endif
+
+do-install: install-app install-conf
+
+install-app:
+ cd ${WRKSRC} ; \
+ for src in $$( ${FIND} . ! -name .cvsignore ) ; do \
+ dst=${PREFIX}/${MYADMDIR}$${src#.} ; \
+ if ${TEST} -d $$src ; then \
+ ${MKDIR} $$dst ; \
+ else \
+ ${INSTALL_DATA} $$src $$dst ; \
+ fi \
+ done
+
+install-conf: install-app
+ cd ${PREFIX}/${MYADMDIR} ; \
+ ${CHMOD} 0640 ${CFGFILE}.sample ; \
+ ${CHGRP} ${MYADMGRP} ${CFGFILE}.sample ; \
+ if ${TEST} ! -f ${CFGFILE} ; then \
+ ${CP} -p ${CFGFILE}.sample ${CFGFILE} ; \
+ fi
+
+post-install:
+.if defined(WITH_SUPHP)
+ ${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.endif
+ ${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/databases/phpmyadmin211/pkg-deinstall-suphp b/databases/phpmyadmin211/pkg-deinstall-suphp
new file mode 100644
index 000000000000..f5991ecbab23
--- /dev/null
+++ b/databases/phpmyadmin211/pkg-deinstall-suphp
@@ -0,0 +1,26 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+case $2 in
+ POST-DEINSTALL)
+ cat <<EOMSG
+The phpMyAdmin-suphp port has been deleted.
+If you are not upgrading and don't intend to use
+phpMyAdmin any more then you may wish to delete
+the %%MYADMUSR%% account, which can be done with
+the following command:
+
+ # pw userdel %%MYADMUSR%%
+EOMSG
+ if [ -d %%PREFIX%%/%%MYADMDIR%% ] ; then
+ echo " # rm -rf %%PREFIX%%/%%MYADMDIR%%/"
+ fi
+ echo
+ ;;
+esac
+
+#
+# That's All Folks!
+# \ No newline at end of file
diff --git a/databases/phpmyadmin211/pkg-install-suphp b/databases/phpmyadmin211/pkg-install-suphp
new file mode 100644
index 000000000000..7bdf484e65ed
--- /dev/null
+++ b/databases/phpmyadmin211/pkg-install-suphp
@@ -0,0 +1,98 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+PATH=/usr/sbin:/usr/bin:/bin ; export PATH
+
+myadmdir=%%PREFIX%%/%%MYADMDIR%%
+myadmusr=%%MYADMUSR%%
+myadmgrp=%%MYADMGRP%%
+
+myadmgcos="phpMyAdmin Owner"
+myadmhome=/nonexistent
+myadmshell=/sbin/nologin
+
+create_group() {
+ local user group gcos home shell
+
+ user=$1
+ group=$2
+ gcos=$3
+ home=$4
+ shell=$5
+
+ if pw groupadd -n $group ; then
+ echo "===> Group $group created"
+ else
+ cat <<-EOERRORMSG
+ *** Failed to create the $group group.
+
+ Please add the $user user and $group group
+ manually with the commands:
+
+ pw groupadd -n $group
+ pw useradd -n $user -g $group -c "$gcos" \\
+ -d $home -s $shell -h -
+
+ and retry installing this package.
+ EOERRORMSG
+ exit 1
+ fi
+}
+
+
+create_user() {
+ local user group gcos home shell
+
+ user=$1
+ group=$2
+ gcos=$3
+ home=$4
+ shell=$5
+
+ if pw useradd -n $user -g $group -c "$gcos" -d $home -s $shell -h - ; then
+ echo "===> Created $user user"
+ else
+ cat <<-EOERRORMSG
+ *** Failed to create the $user user.
+
+ Please add the $user user manually with the command:
+
+ pw useradd -n $user -g $group -c "$gcos" \\
+ -d $home -s $shell -h -
+
+ and retry installing this package.
+ EOERRORMSG
+ exit 1
+ fi
+}
+
+
+case $2 in
+ PRE-INSTALL)
+
+ # Create the myadm user and group if they do not already exist
+
+ if pw user show -n $myadmusr >/dev/null 2>&1 ; then
+ echo "===> Using pre-existing user $myadmusr"
+ else
+ if ! pw group show -n $myadmgrp >/dev/null 2>&1 ; then
+ create_group $myadmusr $myadmgrp "$myadmgcos" $myadmhome \
+ $myadmshell
+ fi
+ create_user $myadmusr $myadmgrp "$myadmgcos" $myadmhome $myadmshell
+ fi
+ ;;
+ POST-INSTALL)
+
+ # Change ownership of the phpMyAdm directory
+
+ echo "===> Adjusting file ownership in $myadmdir"
+ chown -R $myadmusr:$myadmgrp $myadmdir || exit 1
+ ;;
+esac
+
+#
+# That's All Folks!
+#
diff --git a/databases/phpmyadmin211/pkg-message b/databases/phpmyadmin211/pkg-message
new file mode 100644
index 000000000000..af3cc8172318
--- /dev/null
+++ b/databases/phpmyadmin211/pkg-message
@@ -0,0 +1,11 @@
+
+%%PKGNAME%% has been installed into:
+
+ %%PREFIX%%/%%MYADMDIR%%
+
+Please edit config.inc.php to suit your needs.
+
+To make phpMyAdmin available through your web site, I suggest
+that you add the following to httpd.conf:
+
+ Alias /phpmyadmin/ "%%PREFIX%%/%%MYADMDIR%%/"
diff --git a/databases/phpmyadmin211/pkg-plist b/databases/phpmyadmin211/pkg-plist
deleted file mode 100644
index 5c4d59da21a6..000000000000
--- a/databases/phpmyadmin211/pkg-plist
+++ /dev/null
@@ -1,321 +0,0 @@
-%%MYADMDIR%%/CREDITS
-%%MYADMDIR%%/ChangeLog
-%%MYADMDIR%%/Documentation.html
-%%MYADMDIR%%/Documentation.txt
-%%MYADMDIR%%/INSTALL
-%%MYADMDIR%%/LICENSE
-%%MYADMDIR%%/README
-%%MYADMDIR%%/RELEASE-DATE-2.5.6
-%%MYADMDIR%%/TODO
-%%MYADMDIR%%/browse_foreigners.php
-%%MYADMDIR%%/chk_rel.php
-%%MYADMDIR%%/config.inc.php.sample
-%%MYADMDIR%%/css/phpmyadmin.css.php
-%%MYADMDIR%%/db_create.php
-%%MYADMDIR%%/db_datadict.php
-%%MYADMDIR%%/db_details.php
-%%MYADMDIR%%/db_details_common.php
-%%MYADMDIR%%/db_details_db_info.php
-%%MYADMDIR%%/db_details_export.php
-%%MYADMDIR%%/db_details_importdocsql.php
-%%MYADMDIR%%/db_details_links.php
-%%MYADMDIR%%/db_details_qbe.php
-%%MYADMDIR%%/db_details_structure.php
-%%MYADMDIR%%/db_printview.php
-%%MYADMDIR%%/db_search.php
-%%MYADMDIR%%/docs.css
-%%MYADMDIR%%/export.php
-%%MYADMDIR%%/footer.inc.php
-%%MYADMDIR%%/header.inc.php
-%%MYADMDIR%%/header_printview.inc.php
-%%MYADMDIR%%/images/arrow_ltr.gif
-%%MYADMDIR%%/images/arrow_rtl.gif
-%%MYADMDIR%%/images/asc_order.png
-%%MYADMDIR%%/images/browse.png
-%%MYADMDIR%%/images/button_bookmark.png
-%%MYADMDIR%%/images/button_browse.png
-%%MYADMDIR%%/images/button_drop.png
-%%MYADMDIR%%/images/button_edit.png
-%%MYADMDIR%%/images/button_empty.png
-%%MYADMDIR%%/images/button_fulltext.png
-%%MYADMDIR%%/images/button_index.png
-%%MYADMDIR%%/images/button_insert.png
-%%MYADMDIR%%/images/button_nobrowse.png
-%%MYADMDIR%%/images/button_nodrop.png
-%%MYADMDIR%%/images/button_noempty.png
-%%MYADMDIR%%/images/button_nofulltext.png
-%%MYADMDIR%%/images/button_noindex.png
-%%MYADMDIR%%/images/button_noprimary.png
-%%MYADMDIR%%/images/button_noselect.png
-%%MYADMDIR%%/images/button_nounique.png
-%%MYADMDIR%%/images/button_primary.png
-%%MYADMDIR%%/images/button_properties.png
-%%MYADMDIR%%/images/button_select.png
-%%MYADMDIR%%/images/button_smallbrowse.png
-%%MYADMDIR%%/images/button_unique.png
-%%MYADMDIR%%/images/desc_order.png
-%%MYADMDIR%%/images/fulltext.png
-%%MYADMDIR%%/images/item_ltr.png
-%%MYADMDIR%%/images/item_rtl.png
-%%MYADMDIR%%/images/minus.png
-%%MYADMDIR%%/images/partialtext.png
-%%MYADMDIR%%/images/plus.png
-%%MYADMDIR%%/images/pma_logo.png
-%%MYADMDIR%%/images/spacer.gif
-%%MYADMDIR%%/images/vertical_line.png
-%%MYADMDIR%%/index.php
-%%MYADMDIR%%/lang/add_message.sh
-%%MYADMDIR%%/lang/add_message_file.sh
-%%MYADMDIR%%/lang/afrikaans-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/afrikaans-utf-8.inc.php
-%%MYADMDIR%%/lang/albanian-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/albanian-utf-8.inc.php
-%%MYADMDIR%%/lang/arabic-utf-8.inc.php
-%%MYADMDIR%%/lang/arabic-windows-1256.inc.php
-%%MYADMDIR%%/lang/azerbaijani-iso-8859-9.inc.php
-%%MYADMDIR%%/lang/azerbaijani-utf-8.inc.php
-%%MYADMDIR%%/lang/basque-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/basque-utf-8.inc.php
-%%MYADMDIR%%/lang/bosnian-utf-8.inc.php
-%%MYADMDIR%%/lang/bosnian-windows-1250.inc.php
-%%MYADMDIR%%/lang/brazilian_portuguese-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/brazilian_portuguese-utf-8.inc.php
-%%MYADMDIR%%/lang/bulgarian-koi8-r.inc.php
-%%MYADMDIR%%/lang/bulgarian-utf-8.inc.php
-%%MYADMDIR%%/lang/bulgarian-windows-1251.inc.php
-%%MYADMDIR%%/lang/catalan-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/catalan-utf-8.inc.php
-%%MYADMDIR%%/lang/check_lang.sh
-%%MYADMDIR%%/lang/chinese_big5-utf-8.inc.php
-%%MYADMDIR%%/lang/chinese_big5.inc.php
-%%MYADMDIR%%/lang/chinese_gb-utf-8.inc.php
-%%MYADMDIR%%/lang/chinese_gb.inc.php
-%%MYADMDIR%%/lang/croatian-iso-8859-2.inc.php
-%%MYADMDIR%%/lang/croatian-utf-8.inc.php
-%%MYADMDIR%%/lang/croatian-windows-1250.inc.php
-%%MYADMDIR%%/lang/czech-iso-8859-2.inc.php
-%%MYADMDIR%%/lang/czech-utf-8.inc.php
-%%MYADMDIR%%/lang/czech-windows-1250.inc.php
-%%MYADMDIR%%/lang/danish-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/danish-utf-8.inc.php
-%%MYADMDIR%%/lang/dutch-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/dutch-utf-8.inc.php
-%%MYADMDIR%%/lang/english-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/english-utf-8.inc.php
-%%MYADMDIR%%/lang/estonian-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/estonian-utf-8.inc.php
-%%MYADMDIR%%/lang/finnish-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/finnish-utf-8.inc.php
-%%MYADMDIR%%/lang/french-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/french-utf-8.inc.php
-%%MYADMDIR%%/lang/galician-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/galician-utf-8.inc.php
-%%MYADMDIR%%/lang/georgian-utf-8.inc.php
-%%MYADMDIR%%/lang/german-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/german-utf-8.inc.php
-%%MYADMDIR%%/lang/greek-iso-8859-7.inc.php
-%%MYADMDIR%%/lang/greek-utf-8.inc.php
-%%MYADMDIR%%/lang/hebrew-iso-8859-8-i.inc.php
-%%MYADMDIR%%/lang/hindi-utf-8.inc.php
-%%MYADMDIR%%/lang/hungarian-iso-8859-2.inc.php
-%%MYADMDIR%%/lang/hungarian-utf-8.inc.php
-%%MYADMDIR%%/lang/indonesian-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/indonesian-utf-8.inc.php
-%%MYADMDIR%%/lang/italian-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/italian-utf-8.inc.php
-%%MYADMDIR%%/lang/japanese-euc.inc.php
-%%MYADMDIR%%/lang/japanese-sjis.inc.php
-%%MYADMDIR%%/lang/japanese-utf-8.inc.php
-%%MYADMDIR%%/lang/korean-ks_c_5601-1987.inc.php
-%%MYADMDIR%%/lang/latvian-utf-8.inc.php
-%%MYADMDIR%%/lang/latvian-windows-1257.inc.php
-%%MYADMDIR%%/lang/lithuanian-utf-8.inc.php
-%%MYADMDIR%%/lang/lithuanian-windows-1257.inc.php
-%%MYADMDIR%%/lang/malay-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/malay-utf-8.inc.php
-%%MYADMDIR%%/lang/norwegian-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/norwegian-utf-8.inc.php
-%%MYADMDIR%%/lang/persian-utf-8.inc.php
-%%MYADMDIR%%/lang/persian-windows-1256.inc.php
-%%MYADMDIR%%/lang/polish-iso-8859-2.inc.php
-%%MYADMDIR%%/lang/polish-utf-8.inc.php
-%%MYADMDIR%%/lang/portuguese-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/portuguese-utf-8.inc.php
-%%MYADMDIR%%/lang/remove_message.sh
-%%MYADMDIR%%/lang/romanian-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/romanian-utf-8.inc.php
-%%MYADMDIR%%/lang/russian-dos-866.inc.php
-%%MYADMDIR%%/lang/russian-koi8-r.inc.php
-%%MYADMDIR%%/lang/russian-utf-8.inc.php
-%%MYADMDIR%%/lang/russian-windows-1251.inc.php
-%%MYADMDIR%%/lang/serbian_cyrillic-utf-8.inc.php
-%%MYADMDIR%%/lang/serbian_cyrillic-windows-1251.inc.php
-%%MYADMDIR%%/lang/serbian_latin-utf-8.inc.php
-%%MYADMDIR%%/lang/serbian_latin-windows-1250.inc.php
-%%MYADMDIR%%/lang/slovak-iso-8859-2.inc.php
-%%MYADMDIR%%/lang/slovak-utf-8.inc.php
-%%MYADMDIR%%/lang/slovak-windows-1250.inc.php
-%%MYADMDIR%%/lang/slovenian-iso-8859-2.inc.php
-%%MYADMDIR%%/lang/slovenian-utf-8.inc.php
-%%MYADMDIR%%/lang/slovenian-windows-1250.inc.php
-%%MYADMDIR%%/lang/sort_lang.sh
-%%MYADMDIR%%/lang/spanish-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/spanish-utf-8.inc.php
-%%MYADMDIR%%/lang/swedish-iso-8859-1.inc.php
-%%MYADMDIR%%/lang/swedish-utf-8.inc.php
-%%MYADMDIR%%/lang/sync_lang.sh
-%%MYADMDIR%%/lang/thai-tis-620.inc.php
-%%MYADMDIR%%/lang/thai-utf-8.inc.php
-%%MYADMDIR%%/lang/translatecount.sh
-%%MYADMDIR%%/lang/turkish-iso-8859-9.inc.php
-%%MYADMDIR%%/lang/turkish-utf-8.inc.php
-%%MYADMDIR%%/lang/ukrainian-utf-8.inc.php
-%%MYADMDIR%%/lang/ukrainian-windows-1251.inc.php
-%%MYADMDIR%%/ldi_check.php
-%%MYADMDIR%%/ldi_table.php
-%%MYADMDIR%%/left.php
-%%MYADMDIR%%/libraries/auth/config.auth.lib.php
-%%MYADMDIR%%/libraries/auth/cookie.auth.lib.php
-%%MYADMDIR%%/libraries/auth/http.auth.lib.php
-%%MYADMDIR%%/libraries/blowfish.php
-%%MYADMDIR%%/libraries/bookmark.lib.php
-%%MYADMDIR%%/libraries/charset_conversion.lib.php
-%%MYADMDIR%%/libraries/common.lib.php
-%%MYADMDIR%%/libraries/config_import.lib.php
-%%MYADMDIR%%/libraries/db_config.lib.php
-%%MYADMDIR%%/libraries/db_table_exists.lib.php
-%%MYADMDIR%%/libraries/dbg/profiling.php
-%%MYADMDIR%%/libraries/dbg/setup.php
-%%MYADMDIR%%/libraries/defines.lib.php
-%%MYADMDIR%%/libraries/defines_mysql.lib.php
-%%MYADMDIR%%/libraries/display_export.lib.php
-%%MYADMDIR%%/libraries/display_tbl.lib.php
-%%MYADMDIR%%/libraries/display_tbl_links.lib.php
-%%MYADMDIR%%/libraries/dom-drag.js
-%%MYADMDIR%%/libraries/export/csv.php
-%%MYADMDIR%%/libraries/export/latex.php
-%%MYADMDIR%%/libraries/export/sql.php
-%%MYADMDIR%%/libraries/export/xml.php
-%%MYADMDIR%%/libraries/fpdf/README
-%%MYADMDIR%%/libraries/fpdf/font/courier.php
-%%MYADMDIR%%/libraries/fpdf/font/helvetica.php
-%%MYADMDIR%%/libraries/fpdf/font/helveticab.php
-%%MYADMDIR%%/libraries/fpdf/font/helveticabi.php
-%%MYADMDIR%%/libraries/fpdf/font/helveticai.php
-%%MYADMDIR%%/libraries/fpdf/font/symbol.php
-%%MYADMDIR%%/libraries/fpdf/font/tahoma.php
-%%MYADMDIR%%/libraries/fpdf/font/tahomab.php
-%%MYADMDIR%%/libraries/fpdf/font/times.php
-%%MYADMDIR%%/libraries/fpdf/font/timesb.php
-%%MYADMDIR%%/libraries/fpdf/font/timesbi.php
-%%MYADMDIR%%/libraries/fpdf/font/timesi.php
-%%MYADMDIR%%/libraries/fpdf/font/zapfdingbats.php
-%%MYADMDIR%%/libraries/fpdf/fpdf.php
-%%MYADMDIR%%/libraries/functions.js
-%%MYADMDIR%%/libraries/get_foreign.lib.php
-%%MYADMDIR%%/libraries/grab_globals.lib.php
-%%MYADMDIR%%/libraries/header_http.inc.php
-%%MYADMDIR%%/libraries/header_meta_style.inc.php
-%%MYADMDIR%%/libraries/indexes.js
-%%MYADMDIR%%/libraries/ip_allow_deny.lib.php
-%%MYADMDIR%%/libraries/kanji-encoding.lib.php
-%%MYADMDIR%%/libraries/left.js
-%%MYADMDIR%%/libraries/mysql_charsets.lib.php
-%%MYADMDIR%%/libraries/mysql_wrappers.lib.php
-%%MYADMDIR%%/libraries/ob.lib.php
-%%MYADMDIR%%/libraries/read_dump.lib.php
-%%MYADMDIR%%/libraries/relation.lib.php
-%%MYADMDIR%%/libraries/relation_cleanup.lib.php
-%%MYADMDIR%%/libraries/select_lang.lib.php
-%%MYADMDIR%%/libraries/server_privileges.js
-%%MYADMDIR%%/libraries/sqlparser.data.php
-%%MYADMDIR%%/libraries/sqlparser.lib.php
-%%MYADMDIR%%/libraries/sqlvalidator.class.php
-%%MYADMDIR%%/libraries/sqlvalidator.lib.php
-%%MYADMDIR%%/libraries/string.lib.php
-%%MYADMDIR%%/libraries/tbl_change.js
-%%MYADMDIR%%/libraries/transformations.lib.php
-%%MYADMDIR%%/libraries/transformations/README
-%%MYADMDIR%%/libraries/transformations/TEMPLATE
-%%MYADMDIR%%/libraries/transformations/TEMPLATE_MIMETYPE
-%%MYADMDIR%%/libraries/transformations/application_octetstream__download.inc.php
-%%MYADMDIR%%/libraries/transformations/generator.sh
-%%MYADMDIR%%/libraries/transformations/global.inc.php
-%%MYADMDIR%%/libraries/transformations/image_jpeg__inline.inc.php
-%%MYADMDIR%%/libraries/transformations/image_jpeg__link.inc.php
-%%MYADMDIR%%/libraries/transformations/image_png__inline.inc.php
-%%MYADMDIR%%/libraries/transformations/overview.php
-%%MYADMDIR%%/libraries/transformations/template_generator.sh
-%%MYADMDIR%%/libraries/transformations/template_generator_mimetype.sh
-%%MYADMDIR%%/libraries/transformations/text_plain__dateformat.inc.php
-%%MYADMDIR%%/libraries/transformations/text_plain__external.inc.php
-%%MYADMDIR%%/libraries/transformations/text_plain__formatted.inc.php
-%%MYADMDIR%%/libraries/transformations/text_plain__imagelink.inc.php
-%%MYADMDIR%%/libraries/transformations/text_plain__link.inc.php
-%%MYADMDIR%%/libraries/transformations/text_plain__substr.inc.php
-%%MYADMDIR%%/libraries/url_generating.lib.php
-%%MYADMDIR%%/libraries/user_password.js
-%%MYADMDIR%%/libraries/zip.lib.php
-%%MYADMDIR%%/main.php
-%%MYADMDIR%%/mult_submits.inc.php
-%%MYADMDIR%%/pdf_pages.php
-%%MYADMDIR%%/pdf_schema.php
-%%MYADMDIR%%/phpinfo.php
-%%MYADMDIR%%/queryframe.php
-%%MYADMDIR%%/querywindow.php
-%%MYADMDIR%%/read_dump.php
-%%MYADMDIR%%/scripts/check_lang.php
-%%MYADMDIR%%/scripts/convertcfg.pl
-%%MYADMDIR%%/scripts/create-release.sh
-%%MYADMDIR%%/scripts/create_tables.sql
-%%MYADMDIR%%/scripts/decode_bug.php
-%%MYADMDIR%%/scripts/extchg.sh
-%%MYADMDIR%%/scripts/inno2pma.sh
-%%MYADMDIR%%/scripts/remove_control_m.sh
-%%MYADMDIR%%/server_collations.php
-%%MYADMDIR%%/server_common.inc.php
-%%MYADMDIR%%/server_databases.php
-%%MYADMDIR%%/server_export.php
-%%MYADMDIR%%/server_links.inc.php
-%%MYADMDIR%%/server_privileges.php
-%%MYADMDIR%%/server_processlist.php
-%%MYADMDIR%%/server_status.php
-%%MYADMDIR%%/server_variables.php
-%%MYADMDIR%%/sql.php
-%%MYADMDIR%%/tbl_addfield.php
-%%MYADMDIR%%/tbl_alter.php
-%%MYADMDIR%%/tbl_change.php
-%%MYADMDIR%%/tbl_create.php
-%%MYADMDIR%%/tbl_indexes.php
-%%MYADMDIR%%/tbl_move_copy.php
-%%MYADMDIR%%/tbl_printview.php
-%%MYADMDIR%%/tbl_properties.inc.php
-%%MYADMDIR%%/tbl_properties.php
-%%MYADMDIR%%/tbl_properties_common.php
-%%MYADMDIR%%/tbl_properties_export.php
-%%MYADMDIR%%/tbl_properties_links.php
-%%MYADMDIR%%/tbl_properties_operations.php
-%%MYADMDIR%%/tbl_properties_structure.php
-%%MYADMDIR%%/tbl_properties_table_info.php
-%%MYADMDIR%%/tbl_query_box.php
-%%MYADMDIR%%/tbl_relation.php
-%%MYADMDIR%%/tbl_rename.php
-%%MYADMDIR%%/tbl_replace.php
-%%MYADMDIR%%/tbl_replace_fields.php
-%%MYADMDIR%%/tbl_row_delete.php
-%%MYADMDIR%%/tbl_select.php
-%%MYADMDIR%%/transformation_wrapper.php
-%%MYADMDIR%%/translators.html
-%%MYADMDIR%%/user_password.php
-@dirrm %%MYADMDIR%%/scripts
-@dirrm %%MYADMDIR%%/libraries/transformations
-@dirrm %%MYADMDIR%%/libraries/fpdf/font
-@dirrm %%MYADMDIR%%/libraries/fpdf
-@dirrm %%MYADMDIR%%/libraries/export
-@dirrm %%MYADMDIR%%/libraries/dbg
-@dirrm %%MYADMDIR%%/libraries/auth
-@dirrm %%MYADMDIR%%/libraries
-@dirrm %%MYADMDIR%%/lang
-@dirrm %%MYADMDIR%%/images
-@dirrm %%MYADMDIR%%/css
-@dirrm %%MYADMDIR%%
diff --git a/databases/phpmyadmin211/pkg-plist-chunk b/databases/phpmyadmin211/pkg-plist-chunk
new file mode 100644
index 000000000000..271eb110d237
--- /dev/null
+++ b/databases/phpmyadmin211/pkg-plist-chunk
@@ -0,0 +1,7 @@
+@mode 640
+@group %%MYADMGRP%%
+@unexec if cmp -s %D/%%MYADMDIR%%/config.inc.php.sample %D/%%MYADMDIR%%/config.inc.php ; then rm -f %D/%%MYADMDIR%%/config.inc.php ; fi
+%%MYADMDIR%%/config.inc.php.sample
+@exec [ ! -f %B/config.inc.php ] && cp -p %B/%f %B/config.inc.php || true
+@mode
+@group