aboutsummaryrefslogtreecommitdiff
path: root/databases/phpmyadmin5
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2019-12-29 00:20:16 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2019-12-29 00:20:16 +0000
commit78db55225bc8e90eeb1a19e122c9d3dd8b9018ea (patch)
tree2fd03827ac185fd9bf0c98a73944129b19da34cf /databases/phpmyadmin5
parentf4dd09a397a3df9c21900bf7fa86254578ddf936 (diff)
downloadports-78db55225bc8e90eeb1a19e122c9d3dd8b9018ea.tar.gz
ports-78db55225bc8e90eeb1a19e122c9d3dd8b9018ea.zip
Welcome phpmyadmin5
Notes
Notes: svn path=/head/; revision=521250
Diffstat (limited to 'databases/phpmyadmin5')
-rw-r--r--databases/phpmyadmin5/Makefile99
-rw-r--r--databases/phpmyadmin5/distinfo3
-rw-r--r--databases/phpmyadmin5/files/config.inc.php.sample14
-rw-r--r--databases/phpmyadmin5/files/pkg-message.in48
-rw-r--r--databases/phpmyadmin5/pkg-descr34
-rw-r--r--databases/phpmyadmin5/pkg-plist-chunk2
6 files changed, 200 insertions, 0 deletions
diff --git a/databases/phpmyadmin5/Makefile b/databases/phpmyadmin5/Makefile
new file mode 100644
index 000000000000..d87920766a41
--- /dev/null
+++ b/databases/phpmyadmin5/Makefile
@@ -0,0 +1,99 @@
+# $FreeBSD$
+
+PORTNAME= phpMyAdmin
+DISTVERSION= 5.0.0
+CATEGORIES= databases www
+MASTER_SITES= https://files.phpmyadmin.net/${PORTNAME}/${DISTVERSION}/
+DISTNAME= ${PORTNAME}-${DISTVERSION}-all-languages
+PKGNAMESUFFIX= 5${PHP_PKGNAMESUFFIX}
+
+MAINTAINER= joneum@FreeBSD.org
+COMMENT= Set of PHP-scripts to manage MySQL over the web
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cpe php:web,flavors tar:xz
+CPE_PRODUCT= ${PORTNAME:tl}
+
+NO_ARCH= yes
+NO_BUILD= yes
+.if !defined(WITHOUT_PHP_DEPENDS)
+
+# Note: composer.json files in the source list pcre as a required
+# extension, but pcre is compiled into PHP as standard on FreeBSD.
+# spl, libsodium are only required in the bundled vendor code. PMA
+# could, in principle, also use the PHP dbase extension, but it's not
+# available for PHP >= 7.0 and of only minority interest.
+
+USE_PHP= ctype filter hash json mysqli session spl xml
+.endif
+
+# Note: default settings will pull in X11 client support. If you don't
+# want this, either turn off GD in the config dialog, or else turn off
+# FONTCONFIG in the graphics/gd port options.
+
+OPTIONS_DEFINE= BZ2 CURL GD GMP MBSTRING OPCACHE OPENSSL PDF \
+ SODIUM ZIP ZLIB
+OPTIONS_DEFAULT= BZ2 GD MBSTRING OPENSSL ZIP ZLIB
+
+BZ2_DESC= PHP bzip2 library support
+CURL_DESC= PHP curl support
+GD_DESC= PHP GD library support (requires X11)
+GMP_DESC= PHP GMP library support
+MBSTRING_DESC= PHP Multi-byte String support
+OPCACHE_DESC= PHP Opcache support
+OPENSSL_DESC= PHP OpenSSL support
+PDF_DESC= PHP PDFlib support
+SODIUM_DESC= PHP libsodium support (only available for PHP >= 7.2)
+ZIP_DESC= PHP Zip compression support
+ZLIB_DESC= PHP ZLIB support
+
+.include <bsd.port.options.mk>
+
+GROUPS?= ${WWWGRP}
+CFG_FILE= config.inc.php
+
+PLIST= ${WRKDIR}/plist
+PLIST_SUB+= PMA_GRP=${GROUPS}
+
+SUB_LIST+= PKGNAME=${PKGNAME} \
+ CFG_FILE=${WWWDIR}/${CFG_FILE}
+SUB_FILES+= pkg-message
+
+.if !defined(WITHOUT_PHP_DEPENDS)
+
+.for opt in ${OPTIONS_DEFINE}
+. if ${PORT_OPTIONS:M${opt}}
+USE_PHP+= ${opt:tl}
+. endif
+.endfor
+
+.endif
+
+.SILENT:
+
+post-patch:
+ cd ${WRKSRC} ; \
+ ${CP} ${FILESDIR}/${CFG_FILE}.sample ${WRKSRC}/${CFG_FILE}.sample ; \
+ ${FIND} . ! -type d ! -name ${CFG_FILE}.sample ! -name '*.bak' | \
+ ${SORT} | ${SED} -e "s,^\.,%%WWWDIR%%," >${PLIST} ; \
+ ${CAT} ${PKGDIR}/pkg-plist-chunk >>${PLIST} ; \
+ for emptydir in $$( ${FIND} . -type d -empty -print | \
+ ${SED} -e "s,^\.,%%WWWDIR%%," ) ; do \
+ ${ECHO} "@dir $${emptydir}" >>${PLIST} ; \
+ done ; \
+
+do-install:
+ cd ${WRKSRC} ; \
+ for src in $$( ${FIND} . ! -name .cvsignore ! -name '*.bak' ) ; do \
+ dst=${STAGEDIR}${WWWDIR}$${src#.} ; \
+ if ${TEST} -d "$$src" ; then \
+ ${MKDIR} "$$dst" ; \
+ else \
+ ${INSTALL_DATA} "$$src" "$$dst" ; \
+ fi \
+ done
+ @${MKDIR} ${STAGEDIR}${WWWDIR}/tmp
+
+.include <bsd.port.mk>
diff --git a/databases/phpmyadmin5/distinfo b/databases/phpmyadmin5/distinfo
new file mode 100644
index 000000000000..2c2ddd3ffe59
--- /dev/null
+++ b/databases/phpmyadmin5/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1577577632
+SHA256 (phpMyAdmin-5.0.0-all-languages.tar.xz) = cd1c1f1473b82a4d0de298ecadc1bf40e8d9cb4b9bdf44c8813ce7638dee02f2
+SIZE (phpMyAdmin-5.0.0-all-languages.tar.xz) = 8130456
diff --git a/databases/phpmyadmin5/files/config.inc.php.sample b/databases/phpmyadmin5/files/config.inc.php.sample
new file mode 100644
index 000000000000..73f35478b952
--- /dev/null
+++ b/databases/phpmyadmin5/files/config.inc.php.sample
@@ -0,0 +1,14 @@
+<?php
+/* $FreeBSD$
+ *
+ * Skeleton configuration file -- this file is empty on a fresh
+ * installaton of phpmyadmin.
+ *
+ * Copy any settings you want to override from
+ * libraries/config.default.php or visit /phpmyadmin/setup/ to generate a
+ * basic configuration file
+ *
+ */
+
+
+?>
diff --git a/databases/phpmyadmin5/files/pkg-message.in b/databases/phpmyadmin5/files/pkg-message.in
new file mode 100644
index 000000000000..c59745d76ae7
--- /dev/null
+++ b/databases/phpmyadmin5/files/pkg-message.in
@@ -0,0 +1,48 @@
+[
+{ type: install
+ message: <<EOM
+%%PKGNAME%% has been installed into:
+
+ %%WWWDIR%%
+
+Please edit config.inc.php to suit your needs.
+
+To make phpMyAdmin available through your web site, I suggest
+that you add something like the following to httpd.conf:
+
+For Apache versions earlier than 2.4:
+
+ Alias /phpmyadmin/ "%%WWWDIR%%/"
+
+ <Directory "%%WWWDIR%%/">
+ Options none
+ AllowOverride Limit
+
+ Order Deny,Allow
+ Deny from all
+ Allow from 127.0.0.1 .example.com
+ </Directory>
+
+For Apache version 2.4.x or above:
+
+ Alias /phpmyadmin/ "%%WWWDIR%%/"
+
+ <Directory "%%WWWDIR%%/">
+ Options None
+ AllowOverride Limit
+
+ Require local
+ Require host .example.com
+ </Directory>
+
+SECURITY NOTE: phpMyAdmin is an administrative tool that has had several
+remote vulnerabilities discovered in the past, some allowing remote
+attackers to execute arbitrary code with the web server's user credential.
+All known problems have been fixed, but the FreeBSD Security Team strongly
+advises that any instance be protected with an additional protection layer,
+e.g. a different access control mechanism implemented by the web server
+as shown in the example. Do consider enabling phpMyAdmin only when it
+is in use.
+EOM
+}
+]
diff --git a/databases/phpmyadmin5/pkg-descr b/databases/phpmyadmin5/pkg-descr
new file mode 100644
index 000000000000..c81c2d88f74d
--- /dev/null
+++ b/databases/phpmyadmin5/pkg-descr
@@ -0,0 +1,34 @@
+Currently phpMyAdmin can:
+
+ * browse and drop databases, tables, views, columns and indexes
+ * display multiple results sets through stored procedures or queries
+ * create, copy, drop, rename and alter databases, tables, columns
+ and indexes
+ * maintain server, databases and tables, with proposals on server
+ configuration
+ * execute, edit and bookmark any SQL-statement, even batch-queries
+ * load text files into tables
+ * create and read dumps of tables
+ * export data to various formats: CSV, XML, PDF, ISO/IEC 26300 -
+ OpenDocument Text and Spreadsheet, Microsoft Word 2000, and
+ LATEX formats
+ * import data and MySQL structures from OpenDocument spreadsheets,
+ as well as XML, CSV, and SQL files
+ * administer multiple servers
+ * manage MySQL users and privileges
+ * check referential integrity in MyISAM tables
+ * using Query-by-example (QBE), create complex queries
+ automatically connecting required tables
+ * create PDF graphics of your database layout
+ * search globally in a database or a subset of it
+ * transform stored data into any format using a set of predefined
+ functions, like displaying BLOB-data as image or download-link
+ * track changes on databases, tables and views
+ * support InnoDB tables and foreign keys
+ * support mysqli, the improved MySQL extension
+ * create, edit, call, export and drop stored procedures and
+ functions
+ * create, edit, export and drop events and triggers
+ * communicate in 62 different languages
+
+WWW: https://www.phpmyadmin.net/
diff --git a/databases/phpmyadmin5/pkg-plist-chunk b/databases/phpmyadmin5/pkg-plist-chunk
new file mode 100644
index 000000000000..45a66a99133a
--- /dev/null
+++ b/databases/phpmyadmin5/pkg-plist-chunk
@@ -0,0 +1,2 @@
+@sample(,%%PMA_GRP%%,640) %%WWWDIR%%/config.inc.php.sample
+@dir(,%%PMA_GRP%%,770) %%WWWDIR%%/tmp